Download

How to use new Audio Capture Component (4.19) to drive game parameters?

Hi there! I would like to capture the mic from the oculus rift to spawn “breathe” in a winter scene (like here). So I need to safe the volume of the capured mic in realtime in a float variable. In the release notes of 4.19 I found this:

"We have implemented a Microphone Capture Component which allows:

  • Feeding audio directly into a game for use with the Audio Mixer
    -** Driving in-game parameters using real-time amplitude data.**
  • Processing audio with Source Effects or Submix Effects."

I added an audio capture component to my VR Pawn and tried to activate some game logic, but I have no experience with the audio engine and probably missing something very very basic.
Thanks for any advise how to set this up. The rift mic is set as the windows default mic.
andtheand

Screen.jpg

You’ll want to Activate the component.

Try to **Auto Activate **it in Details Tab on a test project, but event does not appear.

Thanks, I had the same problem.

Also, I’m wondering what’s the use of Attenuation settings for Audio Capture components ?! does it affect how sound is being captured ?!

Hey Alllesss, would you mind posting yor BP setup? When I activate the audio component, the “on audio envelope” event fires all the time with a envelope value of “0”. No matter if I speak into the mic or not. Thanks!

It’s exactly like what you posted here. just an Audio capture component with “Auto Activate” enabled. If it sticks to 0 then it might be your mic setup. try checking windows’ recording devices and set the right one to active.

Have same problems. I 100% have active and working audio input. Still get 0

@ newturok: I first had to activate the new audio engine :rolleyes: which is still deactivated by default in 4.19. Check this out: Link

Now it works. Nice!

That helps, thanks.

For getting awesome results out of this will be nice if Unreal add SoundWave out from OnAudioEnvelopeValue event like it is for Audio Component

**New microphone capture component (New Audio Engine Only) (Windows Only)

When this will be android too? <3**

hi, I’ve set my microphone as default and added audio capture component (set to auto active). but somehow I still get 0 from “on audio envelope value” when I speak to the mic. please help.

Did you turn on the new Unreal Audio Engine?

**@dan.reynolds

Hi, I want just play audio from mic to vive headphones. please, can you explain how do i get this?**

ok, when activating Audio Capture - sound from mic auto reproduce in headphones. digging for increase volume and stop other game sounds.

update: found it - new audio class for mic, new sound mix and some like in picture attached Capture.PNG

Hi @6r0m, you don’t have to do a Set Sound Mix Class Override, you can just create a SoundMix Asset that defines the SFX and Mic Sound Classes and just push that when you activate and pop it when you deactivate.

Hi, Dan, Cool! Thank you

Hi, anyone try this to Linux Dedicated server?

I got this error when using Audio Capture Component, anyone know how to fix this?

If the audio capture isn’t working on 4.23 for someone reading this, try it:

  1. try the auto activate, like dan.reynolds and newturok said last page.

and

**2) I did this: **UseAudioMixer=true

Searched for the file:

E:\UE_4.23\Engine\Config\Windows then openned the “WindowsEngine” file and added this last line of code on bold:


[Audio]
AudioDeviceModuleName=XAudio2
; Defining below allows switching to audio mixer using -audiomixer commandline
AudioMixerModuleName=AudioMixerXAudio2

; Defines a platform-specific volume headroom (in dB) for audio to provide better platform consistency with respect to volume levels.
PlatformHeadroomDB=-3
UseAudioMixer=true