How to update SwarmAgent.exe.config?

I am using Unreal Engine 4.9. When I try to use the Build icon to calculate the lighting it appears a Fatal Error window which contains this message:

Could not create cache folder C:\Program Files\Unreal Engine 4.9\Unreal Engine 4.9.0 Improvable\Engine\Saved\Swarm/SwarmCache.
Please update SwarmAgent.exe.config in your binaries folder.

87418-error.jpg

I just created the cache folder it the directory that I mentioned, but nothing happened except that the Fatal Error message did not come up.

Here I want to put the messages in the log tab of the Swarm Agent window:

  1. [StartNewLogFile] Error: Access to the path ‘C:/Program Files/Unreal Engine 4.9/Unreal Engine 4.9.0 Improvable/Engine/Saved/Swarm\SwarmCache\Logs’ is denied.
  2. Starting up SwarmAgent …
  3. … registering SwarmAgent with remoting service
  4. … registering SwarmAgent network channels
  5. … initializing SwarmAgent
  6. … checking certificate
  7. … certificate check has failed
  8. … initializing cache
  9. [EnsureFolderExists] Error: System.UnauthorizedAccessException: Access to the path ‘C:/Program Files/Unreal Engine 4.9/Unreal Engine 4.9.0 Improvable/Engine/Saved/Swarm\SwarmCache’ is denied.
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj, Boolean checkHost)
    at System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
    at Agent.Agent.EnsureFolderExists(String Folder) in e:\Unreal Engine 4.9.0 Improvable\Engine\Source\Programs\UnrealSwarm\Agent\Utils.cs:line 727
  10. ERROR: Could not create cache folder ‘’
    Please update the SwarmAgent.exe.config file in your binaries folder.
  11. … Failed to get the cache location!

Could you please help me to fix the problem?

Thank you.

Hi Ahmad,

Looking at the error reported in the log it seems like you may not have write access to this file location which Swarm Agent then couldn’t create the cache folder needed.

Here’s a couple of things to try:

  • Make sure that you have administration rights for you computer for write access.
  • Make sure that this engine folder is not “Read Only”
  • Navigate to the folder location where SwarmAgent.exe is and Right-Click then “Run as Administrator” to see if that resolves the issue. (Should be located in C:\Program Files\Unreal Engine\4.11\Engine\Binaries\DotNET)
  • Open Swarm Agent application and set a new cache folder location. Follow the instructions here to do so. Try using something like C:/Swarm. You will need to create this “Swarm” folder there before you can redirect it though.

If you’re still experiencing the issue with 4.9 can you try downloading the latest version of 4.11 and see if the issue persists there for you?

Thank you!

Tim

Hi Tim

Thank you so much for your kind Detailed response. I just tried to uninstall UE4 and install that again. I think it had some problem with the directory I defined last time . I did not change the directory (I mean C:\AGA) for the second time and it is working very well know.

Thank you very much.

Ahmad

Ok. Glad it’s working for you now. :slight_smile:

I have the same problem. Arose due to the fact that I changed the name of the Windows account. Tried everything including changing the cache paths in the BaseEngine.ini file
The solution was very simple. In the Swarm Agent, the settings tab, the Cache Folder item, in the Cache Folder line, I entered the path to the new folder in the new Windows account.

was using UE4 and this happened with me also, My Brother fixed this. I will let you know.

was using UE4 and this happened with me also, My Brother fixed this. I will let you know.

thanks!!! you are best!!! help me without my problem