How to turn off soft distance shadow feature?

I noticed there’s a feature which the further the camera is, softer the shadows are. But I couldn’t find the place to turn this thing off. Tried project settings and light settings. I just want some normal soft shadows.


You can do this by adjusting the Light Source Angle in the Light sources Details panel. This will tighten up the Distance Fields shadow to the generated Distance Field Mesh. (Show > Visualize > Mesh Distance Fields).

This may or may not give the results you’re looking for dependent upon the resolution of the generated distance field mesh.

For instance, the mesh will appear rounded on corners for some meshes with lower resolution. Increasing the resolution can help with this though, but you will incur more memory usage for this as well. You can increase the distance field resolution of a mesh by going to the Details panel in the static mesh > Build Settings > Distance Field Resolution (default is 1.0, max is 100). Try increasing incrementally (2, 3, 4, etc) until you get a resolution that works. Increasing to the highest resolution is not always advisable. Most meshes I’ve adjusted have never really gone beyond 10.

I hope this helps.