Download

How to switch between two different Widget Blueprints?

I have two GUIs that I’d like to switch between with a key press; Game GUI and Creator GUI. I have a Begin Play with a Create GameGUI_C Widget (Game GUI) and a Add to Viewport. That displays Game GUI correctly. When I press the P key, I would like to switch to the Creator GUI. Here is what I have setup, but then it seem to keep adding GUIs on top of each other. What node can I use to Remove from Viewport the previous GUI?

Thanks.

I’m not at home, so I don’t know if this will work for sure…but there’s a Hidden attribute that I accidentally activated on mine trying to hide just a single item in my widget…

I’d imagine you can set it to hidden and unhidden based on what “mode” you’re in. Both are active, just one is hidden.

You’re actually creating new widgets each time.

Barring that not working, I’d guess you’d need to destroy the widget then recreate each time.

Also, there seemed to be an issue setting a widget to hidden within the widget blueprint itself, I had to do it from my character BP (or another BP) to get it to work. I was doing this for a zoom reticle.

u have to make a reference for each on and create them in (Begin Play)
then in the flip flop Node A {add to viewport the reference of (Creater GUI)+ remove from parent the reference of (Game GUI)} .

and in the flip flop Node B do the opposite

.it should work now

maybe you should use “remove from parent”

This is better

bb6062c709c8ec1fca59fb836bc158bcd53b3e24.jpeg

Narg

As mentioned earlier - event begin play, reference it

a54f828a6f79822e42107c49f196f922765c5981.jpeg

I am doing a widget game, check this out-my event begin play

0a4346b00312a2c039a0ac2d4549335625a98c36.jpeg

Narg

Haha, that’s sick bro.

When I first started blueprint, I thought it was harder than coding. And in a way it is, but after messing with it for a while it’s starting to be pretty efficient. Stuff like that is fun because it really puts a visual representation of what’s going on behind the scenes in front of your face.

Finished my Zoom reticle effect last night and calling the Hidden attribute worked well.