How to strech an actor in a Matinee

I want to make I guess a platform that extends when a player gets too close to it. I tried extending it in a matinee by adding keyframes but it didn’t work. can you actually stretch an object in a Matinee? (if you need a video example I can give you one)

Hmm… If you’re on 4.18, I’m pretty sure matinee is legacy now. You can try sequencer for a much nicer experience. That said, it seems like what you’re describing could be achieved by interpolating the scale of the platform based on distance from the character.You wouldn’t need sequencer or matinee for that. Just a LERP node, a box trigger and a timeline. Do you need the platform to scale over time once the player reaches a certain point or do you need it to scale a bit more as the player gets closer?

[And here’s a Link to a quick video of me building the thing.][2]

What do you mean by stretch? you can scale the actor by any axis, if you need to scale it only from 1 side you should change object’s pivot to scale it properly.

I want the platform to get farther away from the player once he triggers the box. it will be moving in the X-axis. I will look at the video and see if it works.

stretch meaning I want the platform to move, but instead of move, it’s stretching the platform. I don’t care if the texture gets messed up by doing this because it’s a solid texture.

I made the blueprint but nothing happened and gave me an error saying the blueprint couldn’t compile correctly but it shows a green mark on the side of it saying it was. I can see how this didn’t work is because I never selected the object that I want to be stretched.I think whoever made the video might have left something out.

ok i fixed the blueprint compile error but then when I quit the game it said there were warning errors saying “Blueprint runtime error: accessed none trying to read property ScaleActor from function ‘executeUbergraph_ScaleActor’ from node: scale Actor scale 3D in graph EventGraph in object ScaleActor with description accessed none trying to read property scaleActor” how can I fix this? (it repeats that message about 100 times)

Hmmm… The most likely means your scaleActor variable is not being set. You have to select the actor you want to scale. On your details panel for your box, you will see a dropdown menu that lets you select any actor on the stage. The easiest way to do that is to select there eyedropper next to the dropdown and click on the actor you want to scale. I’m attaching a pic of the details panel. The dropdown is towards the bottom and is called Actor to Scale on my project.

mine doesn’t look like that.

right. I guess I could’ve been more specific. The details panel you’re looking for is not inside the blueprint. It’s on the right hand side details panel in your main level view. In there you’ll see the dropdown. Make sure to select the object you want to scale there.

That details panel is contextual. It will show you a bunch of settings for whatever you have selected on your level. So, if you don’t have your box trigger selected, this could also look different.

Note: Every details panel in ue4 is contextual and will change base on your selection. there are so many options in there that it can get a little hard to keep track of all the things you can do. Often when learning the app, I found myself clicking on different components and different actors on the stage thinking “I know I saw a button for that somewhere.”

it worked. thanks but I have 1 more question. how would I make it only stretch to the X axis only and not both X and Y?

  1. not stretched
  2. stretched

well just check if your endscale value doesn’t have Y scaling more than default.

Well, the simplest way is to make sure your endScale for y and z is the same as your start. You can manually input it, which is viable but tedious if you have a bunch of these platforms. Or you can set the y and z values of endScale to the values of startScale at the end of event begin play. I’d send you a screen grab, but I won’t be in front of my computer till late tonight.

thanks for the answers! it works perfectly now. thank you so much for the help.