Download

How to stop UMG widget opacity increasing over time?

I want to have translucent elements in my widget blueprint, so I set their alpha value to 0.5. In my default HUD I “Create self_hud Widget” and “Add to viewport”, fine. It works and the translucency shows as 0.5 when I start the game, but all widget elements quickly become opaque (as in, it lerps from whatever value I set it to to 1 it seems). I have tried setting the widgets’ opacities to 0.5 in the Graph every tick, but that doesn’t do anything. I have no idea where this code for making the widgets darken to opaque comes from. I tried with different widget blueprints – same problem! I’m stumped!

is this in a parent and child widget blueprint ?

Thanks tozan, you lead me in the right direction. The problem was I was spawning the HUD every tick.