Download

How to stop third person camera from rotating with player?

I’ve started with the third person template and I’m trying to change two things with it that I can’t figure out. Both of these things are in the top down template, but I can’t seem to translate them across to the third person game.

  1. In the top down template, the camera is fixed above the player and doesn’t rotate with the mouse. I would like the camera to do this also in the third person template. The first thing I did was remove the mouse input from the player character, which stopped the camera rotating with the mouse. Then I turned off “Use Pawn Control Rotation” on the spring arm (just like in the top down template), but then the camera rotates with the player now instead. Why??? I can’t see what else is different in the top down template, so not sure why this isn’t working.

  2. I want the mouse cursor to display on the screen when the game has focus (like in the top down template). I can’t find where in the top down template they specify the mouse to be visible. How do I do this?

Well, camera is a child of player (is attached) is it not? If it is, it will move with the player.

Yes, but it is the same in the top down template… but it doesn’t rotate with the player in that one?? I’ve set up the camera and spring arm exactly the same as in the top down template but it still rotates with the player.

OK, I have worked out the mouse cursor. You need to create a Player Controller Class and tick Show Mouse Cursor on its component. Then you have to set this controller into the Game Mode.

I still have a problem with the camera rotating with the player though, even though I have set it all up the same way as the top down template. Makes no sense. Either I’m missing something or there is a bug.

If you don’t want the camera to rotate then make sure the camera’s springarm (“CameraBoom” is usually named) has unchecked the Use Pawn Control Rotation.

Also you might need to set the rotation under Transform to Absolute Rotation (World, rather than Relative), not sure if you really need that though.

Thank you TK-Master. As I said in my OP, I had already turned off “Use Pawn Control Rotation” so that wasn’t the problem. The issue however was with the Transform not being set to Absolute Rotation. Wow I would have never found that! Just a tiny little down arrow to click on to choose between the Relative and World.