How to stop player going in air?

I’m really new to creating my first Arch-Viz project in Unreal.

I’ve imported my geometry, set up for collisions (which works okay), but when I build and play, my player is able to float up to the ceiling (if I’m looking at it and ‘moving’ forwards…)

I just want to walk on the ground.

How can I do that ? How can I make my Actor stick to the ground plane and follow that (a piece of floor geometry that has ramps but is mainly flat).

I’m using a Player Start Actor.


since you say your pretty new i would guess that you probably didnt make a character. you could try importing the first person template character or you could try making your own. if you decided to make your own its not too difficult and you wont need to have a mesh since your doing archvis. really all you would need to do is create a empty character then attach a camera component and setup inputs, theres a ton of tutorials on setting up characters online. alternatively you could import the first person character as mentioned then remove the pieces of it that you dont need such as the arms and gun. to add the first person character to your project do the following: from the main window (the one with your scene) click add new (the green button), then click add feature or content pack, then select the first person one and hit add to project. after all that you will need to set your default pawn to the character you create or the firstperson one. you can set the default pawn via the project settings in the maps and modes section.

let me know if you need more help.