Download

How to start from a specific place when I Play my scene?

Hi everyone!

I want to start my archviz walkthrough from a specific place in my interior scene but when I press play it always starting outside the building. I really don’t know how to fix this. I’ve put a “player start” in the scene but it doesn’t work.
Any help would be appreciated! :slight_smile:

The same thing is wrong in my project as well :frowning:

Do you by any chance have a duplicate player start? Without player starts the level should start wherever your viewport is in the editor. If you’re viewport is inside the building, but playing the game starts it outside - it sounds as if you may have another player start out there.

Just to add: Is this running in-Editor (selected viewport)? If so, check this is set on:

Toolbar → Play <Button> → Spawn Player At → Current Camera Location

Otherwise delete all your in-level ‘Player Starts’ / take back control over the process.
Don’t set a default Pawn Class either in Project-Settings-World-Settings use ‘None’.
Instead use a Gamemode class to spawn your pawn i.e. Spawn-Actor-From-Class.
This node lets you set the exact location where the Pawn will Spawn (no guesswork).

Or

Inside your Pawn / Character class drag Teleport / Set-Actor-Location into the graph.
Set the vector manually using co-ordinates from the world where you want your pawn.
To get the co-ordinates (or the 3D vector etc), drag a Camera or Note into your level.
Copy the Transform -> Location X, Y, Z values into Teleport / Set Actor Location etc.

Or

Drag a Camera or Note into the level. Use BP Get-Actor-Location to get the co-ords.
Connect the output of that to the Teleport or Set-Actor-Location node to set the Pawn…

This is all Blueprints 101…

But if you don’t get this stuff down now it may feel like you’re fighting the engine forever…

Thank you SE_JonF and franktech for your comments :).

I think the problem was my environment (a city background /static mesh) and there was a collision added to it. When i removed the collision I start inside the house when i press Play.

But now I’m not satisfied in the way my field of view is acting. In my viewport I’ve set my FOV to 60 but when i press Play it shows another FOV.

Maybe i should have mentioned I have recently started learning Unreal :).

go to top left corner, you will see a button called Basic, click it and you will see player start , hold it by left clicking it and then drag it to the place that you want it to be in ;D have fun !