How to specify gccversion 4.9 instead of 4.8 for android or linux

I have libraries that require gnu 4.9 and its runtime. Ue4 presently defaults to using gccversion 4.8 when compiling and packaging for android.

Is there a way to specify and/or force the unreal build tool to use gccversion 4.9 of the toolchain? Must be an argument or preprocessor to do this.

Hi gbrill,

Due to the large volume of questions and comments concerning the Engine, we did not have a chance to respond to your post at the time you submitted it. However, if you are still interested, this is what I was able to find out about this issue:

We use clang for Android. We only use ld out of gcc for linking. We use gnu-libstdc++ 4.9 if available in the NDK already:

%NDKROOT%/sources/cxx-stl/gnu-libstdc++/4.9

-So no additional action should be needed. I am closing this issue out for tracking purposes, however, if you are still having a problem specifying gccversion 4.9 in UE4.12.5, please create a new post for that engine version, including a reference to this post.

Thanks,

Steve H.