How to solve engine modules are out of date

Hey, I am compiling my own engine solution because I have made some changes to the engine’s code, but when trying to open my .uproject file, it asks for me to build the modules because they are built for another version. If I press build now, it does something but then it says “Engine modules are out of date, and cannot be compiled while the engine is running. Please build through your IDE”.

I just built the Engine project through visual studio in Development Editor mode so I can’t think of a reason why the modules would be out of date or just why it would not work.


First, in your source folder in your project, check that {nameofproject}.Target.cs and {nameofproject}Editor.Target.cs has “DefaultBuildSettings = BuildSettingsVersion.V2;” in the section base(Target) { … } If it does not work, check the file Engine/Source/Developer/DesktopPlatform/Private/DesktopPlatformBase.cpp in your Unreal Engine source code, look for the line Arguments += " -Progress -NoEngineChanges -NoHotReloadFromIDE"; et remove the two last options : Arguments += " -Progress";

  • Re-compile Unreal Engine - Launch your project and accept the rebuild.

I solved it. Future users that might arrive at this point, make sure the engine and the project are running the same version for the same platform. Because I was compiling the engine for 64 bits and the project for 32 (I don’t know why or how)


Did you change the project to 64 bit or did you change the source to 32 bit?


This solved my problem too in Kubuntu 22.04 and Qt Creator. Before the solution the execution log of my project showed this:

LogInit:       Name: LG STUBBED: FDesktopPlatformLinux::GetNativeFeedbackContext at /home/adib/dev/UnrealEngine-4.27/Engine/Source/Developer/DesktopPlatform/Private/Linux/DesktopPlatformLinux.cpp:450 (GetNativeFeedbackContext)
FULL HD 22''
LogInit:       ID: display1
LogInit:       NativeWidth: 1920
LogInit:       NativeHeight: 1080
LogInit:       bIsPrimary: false
Running /home/adib/dev/UnrealEngine-4.27/Engine/Binaries/DotNET/UnrealBuildTool.exe Development Linux -Project="/home/adib/dev/unrealProjects/MyProject/MyProject.uproject" -TargetType=Editor -Progress -NoEngineChanges -NoHotReloadFromIDE

When I removed “-NoEngineChanges -NoHotReloadFromIDE” from these switches as you instructed, all worked.


You solved my problem UE 4.27 + Ubuntu 20.04…Thanks