Download

How to Show Particles In Sequencer

I just started learning sequencer and am unable to see any particles in my recordings. I am trying to record gameplay, and I have an animation that plays and spawns particles at the same time. However, whenever the animation plays, the particles do not show up on the sequencer recording at all. It shows up fine during gameplay though.

Did you find a solution to this? I ran across the exact same problem. Having the ParticleSystemComponent in the list of ‘classes and properties to record’ does not do anything if you spawn particles, which is weird.

What will work is if you create a ParticleSystemComponent inside your blueprint and activate that system instead of spawning. For me this did not really work either as I had to switch my root motion lock to ‘zero’, which does not affect the particle system so they were not going in the right direction, which is also weird as my ParticleSystem is a child of the mesh skeleton, which does get rotated.

What I did instead was to wrap the particle system inside of a blueprint, that just fires the particle system and then dies. This will then get picked up if you use ‘Record Nearby Spawn Actors’ and play this way.

So if anyone reading this knows why spawned particles are not picked up that’d be good hear because this is a workaround I don’t really want to do. It also does not make sense(?) as particle systems are a class derived from the actor class. Should the ‘Record Nearby Spawned Actors’ say Blueprints instead of Actors?

Either way, hope this helps.

1 Like

i think you gotta trigger the particles in the sequencer. I think i saw it in there somewhere

You guys found any solution? It is such a random thing. Sometimes, after a lot of playing with activate toggle tracks it renders. And the same file then later doesn’t render the particles.

Edit: Just now I tried “triggered” in the particle toggle track and it rendered. Earlier I was using “activate”. Is this the answer??? Only time will tell. Unless it stops forever.