How to Set Up Steam Multiplayer on Mac


I have a project that I intend to use the Steam Online Subsystem with, but have not been able to get it working correctly on Mac. I am using UE 4.25 with macOS Big Sur 11.4. This might not matter but the project is blueprints only.

When I packaged the project (shipping build), Steam multiplayer works perfectly fine on 2 Windows PC. However, I am unable to find any hosted sessions on Mac (doesn’t matter if it’s hosted on Windows or Mac). I’ve tried following the set up instructions for [Online Subsystem Steam][1] but those appear to be for Windows only and I’m really struggling to find tutorials or instructions on how to set up Steam multiplayer for Mac.

When I run the packaged app on Mac, the Steam overlay does not appear (it appears when the app is run on Windows PC). I’ve also tried adding the app via the non-Steam game option in Steam and launching it there but it doesn’t make a difference.

In addition, it looks like I do have the Steamworks folder, although I found it in “Users/Shared/Epic Games/UE_4.25/Engine/Binaries/ThirdParty/Steamworks/” and not where my project file is. I’ve attached a screenshot of what is in that directory at the bottom. I will also attach my set up in DefaultEngine.ini below.

I think I’m just missing something for Mac since it runs perfectly fine on Windows, can anyone please walk me through what’s needed to set up Steam multiplayer for Mac? This is fairly urgent as I’m hoping to deploy this app soon, so I really appreciate any and all help!

Hey - thanks for posting. Have you found a solution to this problem? We are experiencing the same problem, although the network seems to work when testing through the Unreal Editor. The connection problem seems to happen after packaging the game.

Let us know if you can, we would highly appreciate it.


There are quite a few gotchas that can stop the session from being created on the Mac. I have to re-learn all of them whenever I port to the Mac.

Are you launching the packaged build inside of Steam?
Do you have a Steam App ID and is it placed in the correct folder (in the same folder as the executable file) on the packaged build?