Download

How to set up baked normal map in material

This is my workflow:

  1. Modeling and Sculpting Hi-Poly Model.

  2. Retopology a Low-Poly Model.

  3. Unwrap UV for the Low-Poly Model.

  4. Bake AO & Normal Map from the Hi-Poly Model.

  5. Texturing the Diffuse for the Low-Poly Model.

  6. Make the Specular Map for the Low-Poly Model.

I use blender, I made all the steps properly and now I want to import to UE4, however what I found out that my baked normal map from xNormal can’t just simply go to the Normal node in the material editor as it’s a baked texture of the model and not a tileable texture which it’s entire size is used,can someone please help me set up these normal maps.

I also read some stuff about tangents and normals that I didn’t really understand, can someone clear that up for me please.

Thank You!

As long as your mesh is uv mapped, the baked normal map should perfectly fit onto the mesh :wink: -> just add the normal map + connect it with “normal”

normals -> Normal (geometry) - Wikipedia

My mesh is uv mapped and is placed properly, I don’t know what’s the issue really

How does it look like when you add your normal map?

like many solid black and grey lines all over the mesh, although the diffuse functions properly.

  1. Did you manage to set that normal map to your LP in Blender?
  2. A screenshot of the result on UE4 editor by just plugin in the normal map into the normal pin may help figuring out the issue.
  3. Also a screen shot of the normal map attributes and the mesh UVs.
  4. By your words, I believe you might be tiling your other maps with a Coordinates node. You should not plug that node into the normal map UV pin. Because as you noted, your normals are not tiled.
  5. Finally, since UE4 uses PBR materials, the behaviour of your diffuse and specular may differ from what you expect. You can read this to figure which are the differences in the PBR workflow.

Hope any of this helps.

-post a pic of your normal map
-make sure that you have set the mode of the texture to “normal” + the texture sample also to “normal”
-flip the green channel of your normal map -> in the texture settings

These screenshots show the material and then normal map.

These screenshots show the material and then normal map.

&stc=1&d=1442335408

&stc=1&d=1442335372

I would need to see the mesh, but I think that that normal map is not right. There are no gradients between the colors, and it looks like pixels are either absolutely facing right or absolutely facing left.

Also, normal maps usually have the padding set to blue (normal facing up), they are not usually padded with that stripes, like other maps.

I guess your baking was not properly set. I don’t use xNormal, but maybe someone here can help you to set the parameters right.

And if I recall correctly, in the texture details you should set Texture Group to WorldNormal or something like that.

Also, I cannot tell by the screenshot if your light green is facing up or down, but you might have to activate the “Flip green channel” option too, like Fighter noted.

The normal map looks pretty strange. Make sure to take a look at a tutorial that explains how to bake them correctly -> e.g https://www.youtube.com/watch?v=U7PQGgz1RII :slight_smile: