How to set the .exe file's details?

I’m talking about the information like “product name”, “product version”, “copyright” etc that you can get by right-clicking on an executable file, clicking “properties” and then selecting the “details” tab. The obvious answer would be the project settings window and the “description” category, as it has some very similarly named fields, but none of those fields affect the packaged EXE’s info. Those parameters are saved in the DefaultGame.ini and everything. About the only thing I can change is the window name and the “debug info” which is displayed next to the window name. The fields in the file details window are always empty (aside from size, date modified and type: application, of course). I’ve tried a shipping build, a development build, full rebuild, 4.13 and 4.14 versions of the engine, what have you. Nothing helps.

1 Like

Hi project.gheist.
That’s actually not my exact issue, the issue you linked is about the “description” field in the “general” tab, and that actually has my custom name from the project settings. I’m talking about all the fields on the “details” tab. Here’s an illustration (shoulda added it to begin with, to be honest).

Thanks for a speedy reply nonetheless!

Hi Antroid,

This issue (UE-37833) is fixed in 4.15 by PR #2799.


Ah, alright then. Now all I have to do is figure out how to make use of it, but that’s another topic entirely. Thanks again!

The PR linked above addresses all those issues by getting the data from the DefaultGame.ini file.

I just rebuilt the executable using the fresh 4.15 editor version and this issue has not been fixed. The data is in the DefaultGame.ini file, it’s in the “project settings”, but the executable comes out completely empty of file details.

I’m going to guess you’re looking at the top level executable. That is mostly responsible for running the primary executable (which will be different depending on what kind of build you made).

I would also like for that executable to get these details, since that’s where a user would go looking for them. However, it seems that they don’t set them on that one.

The issue is still valid in 4.19. Can’t force to have it working.

Having the same problem.

In UE 4.22, setting the values through the DefaultGame.ini file makes no difference, still. You can edit the exe file in Visual Studio and change the values inside the version.txt but this causes the icon to reset and may cause other problems, as well. After saving, closing VS and reopening the exe for editing, VS says that the exe is corrupted.

Is there any clean way to do this?