Download

How to set resolution of packaged game

I tried changing the preferences resolution (game and stand alone) in the Editor, but nothing applies to the packaged game…?
Is it possible at all to do this, or is it not implemented yet.
It is kind of really weird, that something like this is missing.

You have to use console command for that -> how can i change game's resolution in blueprints - UE4 AnswerHub :slight_smile:

phew…they just need to document stuff like this properly…I just googled the Syntax.

I tried the nodes below. I want to play windowed (not fullscreen). When I package to shipping build and start the build after it is done, nothing happens and it gives me 1280x720.

Maybe if I ask the other way around, someone knows:

  1. Open 3rd person template
  2. go straight to packaging and create shipping build
    What do I have to do in blueprints or somewhere else to have the build run in say 800x600 instead of default? And maybe even to switch resolution in-game?
    (no config stuff…but a solution that is user-friendly for the people who buy the game)

Another way is to create a file called DefaultGameUserSettings.ini in your <ProjectName>\Config folder with the following contents:



[/Script/Engine.GameUserSettings]
bUseVSync=False
ResolutionSizeX=1920
ResolutionSizeY=1080
LastUserConfirmedResolutionSizeX=1920
LastUserConfirmedResolutionSizeY=1080
WindowPosX=-1
WindowPosY=-1
bUseDesktopResolutionForFullscreen=False
FullscreenMode=2
LastConfirmedFullscreenMode=2
Version=5


2 Likes

Yes, but I need to as an option in the game, so that players can change resolution.
The node above does not work! Am I missing something for this node to work with a shipping built?

If you have time and desire to work a little bit with c++ check out this tutorial, it’s pretty straitforward

As I said, use the console command -> r.setRes 1000x500 I just tested it and it should work -> add it into the level bp (you should also be abel to change it during the game) :slight_smile:

Thank you!
Can you try Shipping built as well?
I also got it working, but only in development built. It did not work in shipping built. I was reading on answerhub, that the console is stripped from the shipping built.
https://answers.unrealengine.com/questions/55104/how-to-open-the-console-in-a-packaged-game.html

Hmm I thought that I tried it with shipping, but I will check it again in a sec. :slight_smile:

Edit: Yep, should work with shipping -> I use version 4.6

@Fuchs. Thank’s, that seems to be the only way to get it to work at 2560x1600 fullscreen. My “DefaultGameUserSettings.ini” was empty, and I couldn’t remember the settings…

I tested on another computer and it works, both with Shipping and Development built. I could play 640x480 windowed with the node above in the level blueprint. On loading, the default 1280x720 pops up black and then resizes and the game starts.
It might just have been an issue with the setting of the other computer.

I think it would be nice if Epic added a resolution changing blueprint node. Doing it through the console is not good and doesn’t always work properly. Going through the different versions of the engine, I’ve gotten different results with it. With my current setup, using console commands in ver 4.7 resolution can’t be set properly. It’ll always go to 1920x1080 in fullscreen.

Having some obscure .ini file with some settings in it, that’s just not a good way to do things. Something like a resolution pick node from within blueprint should be there. Even listing your rig’s possible resolutions would be a useful thing. So you can simply list valid resolutions using a blueprint setup.

Oof! Not so simple when you have multiple monitor set-ups. :slight_smile:

Just about every game I have lists valid resolutions, so it’s possible to do it. Multi-Monitor should have no impact on complexity of doing it. A valid res is a valid res, whatever the desktop supports is a valid res. If you then want to go filter out specifics, then you can do so. Like only 4:3, or only 16:9, or whatever. I don’t see it being a problem. I’m sure there are way more complex blueprint nodes than that.

I tried all your mentioned methods - but for some reason I can’t make it work.

I added the Level Blueprint:

That’s it. After that, I am packaging the project. I run the application and the Game starts always in full screen mode of my screen.

I would like to have a window, that pops up and can be closed when needed. Like a new Editor Window, similar to the window you can launch when you press PLAY inside the Editor.

How to get this done?

I also created the mentioned .ini file. But even after creating that file and packaging - nothing changed.
always the same - after starting the app, the game launches in full screen mode.

Thank you so much for any little help,
I really do appreciate that!

I made some progress and wanted to keep you posted in case you are having similar issues.

Steps I did:

  1. After Packaging, I created a shortcut of the app
  2. Right MouseClick → Tab Shortcut → Target: after the code line of you application I added …Test.exe" -r:640x480 -dx12

  • Switch to the Compatibility Tab → Change high DPI settings → checked Program DPI and checked Override high DPI
  • Select Scaling performed by Application

Those 4 steps allowed me to run the packaged application in a smaller framed window. First, if you launch the application it might start in Full Screen. If that’s the case, hit ALT+ENTER together. This switched the application into the Window Mode / Frame.

I hope that helps.

Now, I am running into the next problem I can’t resolve:
After launching the application, the performance is super bad. When I run the game inside of the Unreal Editor, the performance is fantastic. I am getting steady 90FPS.

  • Why is the performance on the packaged game so bad?
  • Is there also a chance to make the FPS-RATE visible in the packaged game?

At least I could see what’s going on.

  • Or do I need to change some of my project settings before packaging?

Thank you so much for any little help - appreciate that!

I know this is a super old thread, but for particular reasons, I needed to use the ini method to set my app to start in a windowed mode. Using 4.24, I can confirm that adding a “DefaultGameUserSettings.ini” (don’t forget “Default” in the file name) using the file content that **Fuchs **suggested did indeed make my app start in windowed mode. HOWEVER, before you do a new package build, make sure you delete your intermediate folder first.

If anyone still wonders how to do it, here is another option. I solemnly declare that this method is working in shipping package :wink:

1 Like