Download

How to set default project and marketplace path

I just got the subscription (!!!) and started downloading all the example projects only to find out that it was putting them on my C:/ drive which is now full.

Is there a way to set the default path for it to place them there, or do I have to move everything over manually after loading it to C?

You can’t adjust the path of the marketplace -> it will be always there where your unreal project folder is, but of course you can move the stuff to another disk

Epic games is currently searching for a solution how you can change that path -> take a look at the other threads about that topic

For projects it should be possible to change their path -> a window should appear when you create your new project

I installed it to D:/Program Files/Unreal Engine/, yet the marketplace stuff ends up in Documents/Unreal Projects/ on C.

Oh. Yep, it will move your stuff into the document folder, sorry for the mistake :slight_smile: -> but as I said, regarding to the threads that I read, it’s not possible at the moment to change that

Moved all the stuff where it belongs… awesome so far!

If you’re using Windows, you can do a folder redirection.

I’m not sure if we’re allowed to link to other web pages, here’s the page to Microsoft on how to do it.

If running windows you can just use a symlink betwee locations. In a command prompt you can do

mklink /J “SOURCE” “DESTINATION”

so for me I used

mklink /J “c:\Users\Mathew\Documents\Unreal Projects” “F:\UnrealEngine\Unreal Projects”

Make sure the source does not exist when you do this or you will error out so move the files out of the c:\ drive before you do the link

Check this answer here Directory settings for UE4 Launcher? - UE4 AnswerHub

Default Project Directory for the Launcher:

Edit the following file: %localappdata%/EpicGamesLauncher/Saved/Config/Windows/GameUserSettings.ini

Set: CreatedProjectPaths to path of your choice.

Default Project Directory for the Engine:

Edit the following file: %localappdata%/UnrealEngine/{UE_VERSION}/Saved/Config/Windows/EditorSettings.ini
Change {UE_VERSION} to match version you are using (4.23, 4.24, 4.25, etc.)

Set: CreatedProjectPaths to path of your choice.