Download

How to set default level?

This might be a bit of an odd question, but how do I tell the engine what level to load when it boots up a project?

I ask this because I need to know for packaging purposes, so Unreal doesn’t open a blank level whenever someone boots up my project.

For instance: I have two levels: MainMenu and CharacterCreate. I want MainMenu to be opened up whenever someone loads this project to edit it, but it always opens up to a blank level instead.

Hi,

Go to the Edit Menu->Project Settings->Maps&Modes and there you can define the game’s and the editor’s default map separately.

But how do you get it to save that in v4.18.3? Mine keeps reverting back to the original default level.

Having the same issue in 4.18.3, loading into a totally blank map (black screen) in builds. Having to open our main map via console command (tilde key) which we cannot do in shipping builds.

Is this a 4.18 issue or is something wrong with our Game Instance class perhaps?

Same problem here with same version. Have you managed to fix it? I change the name of the project and the Default level, but when I export the game to android appears the old name, and the old level default. :S

Same problem here. I tried fixing redirectors on my maps folder, but didn’t have any and still not working. I’ve posted in UDN and hoping to get an answer soon.

I have some general solutions that helped me 90% of time.
Might be a long shot because I haven’t encountered same problem but quite similar. Here are few tips that sometimes might help and helped me many times:

  1. Try different storage drive if you can, UE sometimes doesn’t like either custom characters outside basic ASCII or is unable to obtain sufficient privileges to update data.
  2. Remove Saved and Intermediate (fair warning though, back it up before removing, it contains some editor settings, colors of folders etc. not essential to your project but might to you)
  3. Migrate if you can your project to blank and package/work from there, I know this is not the best solution but as last resort is better than nothing.
    I hope at least some of this helps.

Any solution to this?

don’t remember exactly where it is, but in your 'documents> unreal projects> ‘your game’ ’ look in the config folder and look in the .ini files (notepad is fine) and at the top somewhere will be the ‘default game’ or startup game or something to that effect… change the map name to the map name you want for default or start map (make copies just in case (smile))… sometimes the maps and modes thingy bugs out and you have to do it by hand… but don’t forget to go back and set ‘default game’

Thanks for the tip @northstar! I just had the same issue. Even though my project settings were pointing to the correct level, the engine was still trying to load a different level when opening my project. I actually found it in the DefaultEngine config file under “EditorStartupMap” (second paragraph).

Thanks Kontor it was really helpful

Thanks Kontur - fixed it right up.