How to save Widget Reflector's application scale setting?

Every time I open the editor, the application scale setting is reset to 1.0. Is there a way to save it between sessions?

For those who don’t know where this setting is located: MainMenuBar->Windows->Developer Tools->Widget Reflector.

Prior to 4.12, increasing the application scale caused some issues when selecting objects in the 3d viewport. Appears to be fixed now.

I am having the same issue in 4.18. Can someone tell us how to save the scaling setting in the Widget Reflector?

Having same issue. No one found the answer?

Hey there, not sure if you guys figured out the issue but to fix this issue all you gotta do is to append -nohighdpi to your UE4 launcher and that should solve the issue.
Other way is to change the widget scale float inside the engine and then just recompile the engine. The float is here: Engine/Source/Runtime/ApplicationCore/Private/GenericPlatform/GenericWindow.cpp>FGenericWindow::GetDPIScaleFactor() => just change the return value to whatever you want and recompile the engine.

Disabling hidpi is not the same, things are bigger but blurry and there’s no control on the actual scale size like with widget reflector.
This is driving me nuts :stuck_out_tongue:

Hey its 4 years later and it seems this problem persists in UE4. Could you help walk me through your second option of recompiling the engine?

Cheers

I just created a pull request for this:
https://github.com/EpicGames/UnrealEngine/pull/7436

I support this. Working in 1440p+ is a pain without being able to easily resize the font.

Is there any way to save the WIdget Reflector scaling setting so it doesn’t reset every time I start the engine? Any solution?? 2022!!

FSlateApplication::Get().SetApplicationScale(2.0f);

Well, that doesn’t really do anything. In my case I set it to 1.25, which is what I normally set the application scale to in the widget reflector. But when I launched either one of my projects, or started a new project, the scale was the same, which I confirmed by opening the widget reflector and seeing that it was 1.0.

Does anybody know of a way to achieve this? I’m working on a Macbook Pro 16", and the text in the details pane in Unreal is insanely small. I know my eyesight is not perfect, but for most programs I’m fine. But Unreal makes the text so small that I have to set the screen resolution to scaled rather than the native one. And that makes Unreal slightly better, but it sucks real estate space from everything else.

Now, when I did a search for SetApplicationScale in the full 4.23 install directory, two files came up, SWidgetReflector.cpp and SlateApplication.h. I opened both in Xcode and they both have a lot of code about the app scale, and DPI, but I couldn’t find one that has an actual number that I can enter to change the default.

Maybe someone with more knowledge of programming can go into those files and see if there’s a way. I may be using an old version because I’m forced to, but when I launch UE5, it’s the same, everything in the details pane is microscopic, and that’s a huge design oversight, because when you think about it, the place where you need to be able to read text the most is the place where you adjust lots of things, which is the details pane.