How to Run Switchboard Listeners in 5.4 without the Unreal Editor (+ Error Log)

hello

My goal is to run ndisplay without the Unreal Editor. This is because I don’t want to have to install the Unreal Editor on every rendering PC.
So I copied only the required configuration folders for switchboard and switchboard listener from Unreal 5.3, ran them, and connected them, and both switchboard and listener worked fine, showing ndisplay well.

However, my project needed to be upgraded to 5.4, and I again had to run the 5.4 version of the Switchboard and Switchboard Listener without the Unreal Editor installed.
In doing so, I ran into a problem.

I’ve noticed a few differences between Unreal 5.3 and 5.4.

  1. 5.4 seems to have passwords - SB Listener trying to find transportkey.key and transportcert.pem (am I right? I don’t remember 5.3 having password).
  2. the SB Listener has a new UI and additional optional features.

v5.3

v5.4

I tried to do the same thing in 5.4, the way I tried to do it without the editor in 5.3, but I got a lot of errors (probably because there are a lot of PNGs, fonts, etc. that the listener relies on) and I tried to fix it, but I can’t do it anymore, so I’m asking here.

Double-clicking on a SB Listener.exe in version 5.4 should result in a popup like this.

And the log looks like this
SwitchboardListener_2.log (27.3 KB)

All you need is for the Listening feature to work as in 5.3. Is it possible to run the 5.4 version of SB Listener that way?
Or is there a way to get the 5.4 SB Listener to work without the editor?

Hi @genie0774 welcome to the community!

Have you tried to hunt down these files that are mentioned in the log?

LogWindows: Failed to load 'aqProf.dll' (GetLastError=126)
LogWindows: File 'aqProf.dll' does not exist
LogWindows: Failed to load 'VtuneApi.dll' (GetLastError=126)
LogWindows: File 'VtuneApi.dll' does not exist
LogWindows: Failed to load 'VtuneApi32e.dll' (GetLastError=126)
LogWindows: File 'VtuneApi32e.dll' does not exist

@Pixel_Punk Thanks for the help!! but that error log was also showing up in a working SBListener, so I didn’t think it was an issue.

I solved it in the following way.

  1. open Engine\Binaries\Win64\SwitchboardListener.target and you will see the files that SBListener depends on. Import those files matching the path.

  2. Import the .ini files inside Engine\Config.

At this point, SBListener should be running normally!

  1. Connect to Switchboard and look at the logs like ‘Could not find~’ and import the additional files you need.
1 Like