Download

How to run 4.5 editor in debug mode with hot reload?

Hi,

I’m looking for some tips for:
How to run 4.5 editor in debug mode with hot reload?

I did add a -debug on my shortcut so the editor load the debug DLL, but hotreload is not working as VS can’t write the new dll.

Thanks,

No one have issue or no one use the hot reload system in debug?

Thanks,

The way i currently work with hotreload, and its the way i am assuming you need to, but i may be wrong as i am no expert with UE4. Is i detach the debugger, rebuild and that triggers the hotreload, and then i just re attach the debugger. There may be a better way to go about it, but at the mo moment that is how i have found to be able to hotreload

Thanks Pada, this is exactly what I was looking to do, but unsuccessfully.

Did you succeed with it with launching the editor with the -debug argument? It’s for use the dll from debug configuration and not the development ones.

thanks,

have you tried changing the build settings in visual studio to one of the debug outputs so that it will build the right DLL so that hot reload can pick it up?

based on what you have it set to the DLL’s name changes

In fact, when I built the Debug Dll, they were in “not writable” so the build failed. I was wondering if the Editor was able to work on the Debug DLL as with the development one and be able to “release” them for hotreload"
I will try again tonight and see how I can do that as everyone succeed in this, it must be something wrong on my side ^^

If you want to hot-reload using debug DLLs make sure you set the VS configuration to ‘Debug Editor’ (not Debug Game). The -debug param is not really relevant here. Also, if you only trigger hot-reload from the editor then you don’t really need to detach the debugger while making changes to the source files because we create new DLLs (with special suffix) each time you hot-reload. However, if you want to hot reload from VS by simply rebuilding the selected game project that’s currently running in the editor, the debugger can’t be attached. If it says the DLLs are read-only then I’d make sure they don’t have the read-only flag set on them in Windows Explorer. If you’re still unable to hot-reload, please send me the output log (from the editor or VS depending on what you use to hot-reload) as PM so I can look into it further).

FWIW, when working on hot-reload improvements I almost exclusively used ‘Debug Editor’ configuration and it all worked fine.

ok I did a test:
I’m in 4.5.1
In DebugGame Editor I have this error ->LINK : fatal error LNK1104: cannot open file ‘C:\Engine\MyGame\Binaries\Win64\UE4Editor-MyGame-Win64-DebugGame.dll’, if I close the editor evrything build as expected. Editor was launched with -debug.

In DEvelopment Editor, UnrealEditor close immediatly when trying to reload the dll, but I can compile. It’s the hot reloading that’s not happening correctly and I have no error, no crash log… Editor was launched by double clicking on the uproject file.

Thanks for your advice,

@Robert,
Where can I find the log you need?

There’s a know issue with “DebugGame” Editor configs and hot-reload. DebugGame is a strange hybrid of Development Engine DLLs and Debug Game DLLs (hence the name DebugGame). Try “Debug Editor” instead and let me know.

what is “debug editor”? is it “development Editor”?

Robert refers to ‘Debug Editor’ as highlighted in the screenshot:

Debug.png

Thanks Moss, but I don’t have that :frowning:
How can I refresh the configuration list?

I dont see Debug Editor either… I do have development editor.

I believe the Debug Editor configuration is only available if you build the engine from source, the launcher version isn’t shipped with debug DLLs.

@Robert,

Could you please confirm what configuration I should use for Hot Reload?
Also, could you please explain us why we have different configuration settings in VS?

thanks,

@Others,
Did you successfully used the Hot Reload function? Is it by clicking the button in the editor or by building again in VS?

thanks,