Download

How to reverse Y axis using the mouse in the editor?

Where are the preferences to reverse the mouse settings when moving objects within the editor? I saw where you can reverse the input when in Play mode, but I’m at a loss for the other.

Thanks.

I think there’s no such option for this. At least in editor. May be modifying some ini’s or something like that.

Changing some settings in the ‘BaseInput.ini’ file might help you, like WetBass said.


+AxisConfig=(AxisKeyName="MouseY",AxisProperties=(DeadZone=0.f,Exponent=1.f,Sensitivity=0.07f))

Maybe changing the Exponent to -1.f and restarting the editor might flip the axis.

That did it, thanks!

Actually I take that back. The editor works, but as soon as I activate Play mode the y axis is pointed down and will not change.

Hm, try reverting the changes to BaseInput.ini and open BaseGame.ini.



[/Script/Engine.PlayerController]
InteractDistance=512
InputYawScale=2.5
InputPitchScale=-1.75
InputRollScale=1.0


Just guessing, but changing one of those might globally override the PlayerController and invert your axis. Try setting InputPitchScale to positive 1.75.

I tried changing this value several times but for me it seems to have no effect whatsoever.

All I want to do is invert the mouse Y-axis when navigating the viewport.

I’ve found 2 “BaseInput.ini” files that seem relevant, one located within the “4.2” folder (the version I currently use) and another within the “Launcher” folder. I tried adding the “-” sign separately for one .ini file at a time and both together but none had any effect on the viewport navigation. I restarted the editor between each try.

If the above tweak is supposed to work, then any info on what I might be doing wrong would be much appreciated.

Thanks in advance!

-C-

Any further information on this? I really need the y-axis inverted in the editor as well.

http://waynelee3d.com/blog/2014/03/21/inverting-the-mouse-in-unreal-engine-4/

I changed all the “Exponent” values in all the BaseInput.ini files. Still no mouse inversion in the editor. The above link works for inverting in game, but how do you invert in the editor?

Has anyone been able to get this to work in 4.7?

Thanks

Bump just wanted to see if anyone has gotten this to work in 4.7. It feels like maybe I am just doing something wrong? Surely the engine is far enough along to support such a simple feature…

Any updates? My brain hurts from having to switch between inverted/noninverted in play/edit mode.

sad bump :frowning:

Hi Zeal, if you aren’t having any luck here, try AnswerHub. You’ll have more luck getting an answer that way.

Bump! I also want to change the look axes and also for the mouse panning.

Did anyone make these changes into the UE4 source code and recompile the engine? Anyone have a quick thing I can ctrl+f for to find it?

PS: I shouldn’t have to recompile the engine to change editor mouse controls…

Can now do in the interface:
Click on Edit from the main menu
Choose Editor Preferences
Under Level Editor section in left menu choose Viewports
Check box that says Invert Mouse Look Y Axis
Click Set as Default button

But if that doesn’t work you can try:
Go to \Program Files\Epic Games\UE_4.24\Engine\Config
Edit file BaseGame.ini
Under section [/Script/Engine.PlayerController]
Change InputPitchScale= to a positive number
Restart the Unreal Editor

1 Like