How to resolve application error 0xc000007b with Epic Games Launcher?

i just installed epic games in my computer but it won’t open. when I run the application as administrator, the updater showed but after it finished, the application error shows up again. i tried 2 suggestions i found in the internet. first is extracting the dll files from the .cab files in DirectXRedist folder. second is running the LauncherPrereqSetup_x64.exe. but the error still occurs. how can this error be resolved? here are some screenshots:





Did you try this ?

yes. it doesn’t resolve the error.

Unfortunally, i think Ubisoft Support and Microsoft support as far competent than every people on this board, and it’s normal, it’s their product.

If they don’t find, i don’t think unfortunally you will get any answer.
I would advice you to maybe start from a fresh windows installation (if you really want epic launcher).

For the refund, i know refund ask are manually handled by epic, as you start this issue before the refund time, they will normally refund you (I think ?).

The thing is I don’t want a refund. I’m happy with my Civilization VI purchase and all I want is the updated

The fresh windows installation is not an option for me as I would lose Dell specific software which I can’t re-install afterwards :frowning:

Lets hope there will be some solution in the future.

Hi all,

Just to mention that I faced this issue about month and a half ago and there is still no resolution.
I’ve tried litterally every single option from the net including:

  • reinstalling the launcher
  • adding/reming DLL files
  • reinstalling all kinds of additional stuff like DirectX, C++ Redist. and so on
  • shortcut target amendments

I’ve contacted EPIC support and bounced several times accross 5 different repesentatives with increasing level of expertise and their final verdict is that it is a “windows problem” and I should contact Microsoft.
Which I did three times during this whole communication - two of which was with remote access by Microsoft reps and it did not resolve the issue.

I would really like to know how to resolve the issue as per standard this happened few days after the official time for refund as per EPIC’s T&C.