How to remove air resistance entirely?

I’m making a grappling mechanic that uses a single impulse to launch the character to exactly where the player wants to go. All the math is correct, but I’m falling short because of air resistance. I’ve tried changing the default fluid friction in the project settings, but no matter what I do to it, it seems to have no effect. I’ve also tried surrounding the area with a custom physics volume that has zero fluid friction- same deal.

Either I need to account for air resistance in my launch calculations (which would be a royal pain) or I need some way to turn it off for grapple launches and then back on afterwards. (That would feel more satisfying anyways, I think)

Would increasing the player mass mitigate the felt resistance, is it not dependent on mass? Just any information on how the air resistance works would be greatly appreciated.

Is the resistance built into the default character control scheme? If so, how do I access and change it?

Assuming you are just launching the character and letting it naturally enter a falling state?

The default settings in the CMC for Jumping/Falling seem to suggest it would be applying no friction, are you sure the problem is friction and not gravity?

If not, maybe try putting the character into Flying mode.

That assumption would be correct.

I am sure it is friction. The character noticeably slows down in the forward direction, and even stops entirely for larger jumps. There’s some force acting on the character that’s actively slowing it down, although I suppose I can’t be certain where it’s coming from.

Strange. Just took a quick look through UCharacterMovementComponent::PhysFalling() and the only things that should be relevant are the Friction and Braking Deceleration, assuming here no root motion and no funny gravity (i.e. gravity is -Z). The Z component of velocity will change with gravity of course, but lateral velocity should be maintained (with the default settings).

So I just threw together a test, and it did not go as expected.

Because when I claimed with default settings there should be no lateral friction or deceleration I was not looking at a fresh CMC. My bad!

Default value for ‘Breaking Deceleration Falling’ is actually 1500.0, with that changed to 0 and this setup:

I see:

Which looks better :slight_smile:

Thank you, that worked to get rid of the air resistance. Now I’m overshooting for some reason, but I’m sure that’s just a calculation error. Thanks for the help.