Download

How to refresh Static Mesh components of a Blueprint

I have a Blueprint that contains multiple instances of a mesh that I created with the UE4 Modeling plugin (the one that’s in beta status, introducing a Modeling mode in the editor). Everything is working as intended, but I’ve run into two challenges. The first of these I have worked around on my own, but wanted to mention as beta feedback. The second I haven’t solved yet, hence this post seeking advice. I’m coming to UE4 from other tools, so please pardon a question that is probably rather elementary. (I did RTFM but didn’t find an answer there.)

First, there doesn’t seem to be a way to invoke the Modeling mode when inside the Viewport of a Blueprint. Perhaps this is possible, but I couldn’t find a way to add the Modes selection to the toolbar in the Blueprint Editor. I worked around this, after some experimentation, by dragging the original mesh asset into a level in the main Viewport, then editing it there.

Second, I can’t seem to propagate changes of a mesh asset into a Blueprint that has multiple child components (Static Mesh Actor) that refer to the mesh I have edited. I’ve tried doing a “save all” as well as making sure the mesh that I edited is actually the one to which the BP refers. Even restarting the editor doesn’t help. I feel as if I’m missing some really trivial step here, but I didn’t see this discussed in the online docs. Can someone point me in the right direction?

I don’t think this is directly relevant, but one of the changes I made to the mesh was to add three material slots. The instances in the Blueprint don’t show the additional slots in their Details panel, nor do they reflect changes to the default material instances I assigned on the mesh asset.

As a meta-question, I’d also like to know if it’s possible to have a BP not show its components (by default) in the World Hierarchy window. I’m going to have a lot of BPs that contain multiple child components and even hierarchies of Scene Actors, and since these things aren’t directly selectable or editable in the main Viewport, I’d like to simply hide them. I know how to collapse the BP in that window, but by default these are expanded which leads to massive editor clutter.

Thanks for any recommendations or pointers to docs I’ve overlooked.

Double click here

When you refer to child components, do you just mean components, or do you mean ‘child actor components’? Totally different thing.

If they are static mesh components, this should happen the moment you save the mesh in the mesh editor.

If you’re seeing all the components of a blueprint in the editor viewport, you probably just need to close that part of the actor detail window:

Before:

After:

Thanks for a wonderfully detailed reply! My responses to your questions, and results of trying the suggested actions, are below.

When you refer to child components, do you just mean components, or do you mean ‘child actor components’? Totally different thing.

I’m sorry, I meant “child actor components”.

Experimentally, I tried adding a static mesh component as a child and attached the appropriate asset file to it. This works as you indicated, with respect to being instantly updated. (Hooray!) If I double click it as shown in your first image, it brings up the standard mesh editor but not the new Modeling mode from the plugin. Here’s what I get:

The one I want is this:

So far I’ve only found this to be available from the viewports in the main window, which is okay – but it would be great if that could be invoked within the BP editor. OTOH, I realize this plugin is pre-release, so I’m not complaining – just checking to see if I overlooked an easy way to do this. :slight_smile:

The world hierarchy question I asked may not have been clearly stated, so let me illustrate with some screen shots (which is what I should have done the first time – sorry!).

This is the area I think you were explaining how to close:

I hadn’t noticed the resizing option for that, so thanks for pointing this out! That said, the area that I want to influence is here:

As you can see, there are a lot of those “static mesh actor” entities, and AFAICT the only thing you can do with them is toggle their visibility. A left-click on any of these simply selects the parent. So I’d like to have this part of the world outliner collapsed by default for each BP.

Right, I see your problems, all subtly different from the ones I assumed :slight_smile:

I’m afraid I don’t think there’s an answer to any of them! :upside_down_face:

1 Like

No worries, @clockworkocean – I still learned some new tips from your reply, so it’s definitely appreciated. :smiley:

1 Like