How to reduce CPU load for the UE4 editor?

UE4 had a high CPU load (around 120%) on my Macbook Air 2012 running El Capitan with the latest actualisation when UE4 editor is open with the 2d platformer template. I had to reduce the Engine Scalability Settings to the minimum and lock the maximum frame rate to 15 FPS on the editor but the CPU load is still around 30%. Is there something else I can do to keep the CPU load to the minimum? Maybe some kind of rasterisation on editor UI.

Same Problem here. In another post one of the members of staff confirmed to address this issue ( [BUG] High CPU Usage First Launch and Later - Debugging, Optimization, & Profiling - Unreal Engine Forums ). Although, you notice the answer is about two years old it still persists. In comparison, Unity 5 does not expose this behavior at all. I’m wondering why it hasn’t been tackled sufficiently yet. Seems like everyone using UE4 runs at least an i7 capable of handling 8 threads which - if the amount of activate threads during idle remains at most 2 - may not seem to be an issue as it only loads up to 25% onto this kind of CPUs :P. Nonetheless, what is the engine doing in the background while idling? Maybe I should get a slightly bigger shoulder to carry this chunk… like… Intel Xeon E5 2667 v4 with 22c/44th…

Ok, one way to reduce the CPU-load from 50% on my system to about 15% when being in Viewport mode is to set uncheck “realtime” (see figure)

However, when idling around in the EventGraph/Blueprint the CPU-load is back on 50%.