How to properly use Move to Location in multiplayer?

Hi there, so last night I decided to make a small multiplayer top down rpg project and having a quick look at it I found out that the example top down project doesn’t support networking so I researched it a little and found an [old post][1] here explaining how to do it with a proxy pawn and an AIController so I used that, but after getting it all setup my movement just doesn’t seem to work. I decided to leave it for today as I was tired and probably missed something stupid but after looking it over and debugging whatever I could think of I still couldn’t figure it out.

The destination location gets updated correctly, pressing the move button calls the following events/functions but once Move to Location gets called nothing happens. I have my navmesh setup (the whole level lights up green when I press P) and I’m getting a “Request Successful” returned from the move node when I press far from the character and “Already at goal” when I press close, I just can’t figure out why it doesn’t want to move.

The blueprint is basically just calling the function and as it can be seen in this screenshot it’s getting called with no problems (this happens in the Character Controller, the AI Reference is also the correct one and is possessing the Player Character).

I tried even just going and moving the AI to random locations from the AI controller itself but the result was the same. What I missing to make it work?

Well… I just solved it and as I expected it was a stupid mistake. It probably won’t be a useful answer for others but my mistake was I had a movement speed float in my variables which was set to 400 or so I though as it clearly said 400 in the defaults, but I’m not sure if it’s a bug or something if you duplicate a variable that has set defaults and you don’t change it manually in the new variable it will actually have a value of 0 while showing a number. All I had to do was change that 400 to something else and recompile (just compiling didn’t do the job)