How to projectile not colliding with player

If player has physic and projectile also how to tell to projectile to ignore player , don’t collide with it ?

You can create a collision channel for proyectiles.

https://docs.unrealengine.com/latest/INT/Engine/Physics/Collision/index.html

Hi Galeon,

If you set the collision on your projectile to custom you can tell it to ignore pawns. If you want it specifically to ignore your player character but not other pawns, you can do so through blueprints, in which you specify that you want to ignore the player when checking if the projectile hit anything.

Actually the collsion component has a node called ‘Move Ignore Actor’ (C++) or '‘Ignore Actor’ (Blueprint) where you can specify an Actor whcih should be ignored by the collsion compoenent. So once you spawn the projhectile, get a reference to its CollsiionComponent, and add the Pawn (or whoever fires the projectile) into the ignore list using that node.

1 Like

Thanks , very usefull.

Just wanted to mention for posterity, if you’re making a collision channel as DomusLudus suggested, you’ll need to make both a “Player” collision channel (copy the settings from pawn) and a PlayerProjectile collision channel (copy the settings from Projectile (added when you insert the First Person Content) and then just turn off each other in the profiles. IE, In Player you want to Ignore PlayerProjectile and in PlayerProjectile you want to ignore Player. This requires both a new Object channel and preset for both.