How to programmatically disable hair simulation

When spawning a MetaHuman character and then playing a sequencer, after the sequence has finished playing and the control return to the character, the hair are a mess.

I would like to disable hair simulation during sequencer…

I would like to necro this valid question, which, to my best knowledge, has still no satisfying answer.
I have a similar issue. At runtime, I have a metahuman with haircards + simulation enabled. I then turn my MH body into ragdoll (body simulation enabled) and then I unturn ragdoll mode (body simulation disabled) then my metahuman hair is a mess. I would like to be able to access from the hair the groom, then physics, to be able to set hair simulation off as is possible when editing the groom asset directly. But it seems that I can’t access the simulation flag from the Hair’s groom variable in the Metahuman blueprint. So how is it possible to disable hair simulation (or more generally dynamically change values from the groom/card/mesh/physics variables) at runtime ? For what it’s worth, my UE version is 4.27.2.

Here’s how I disable all hair simulation on a MetaHuman at runtime. This is called by the BeginPlay event in this blueprint:

1 Like