How To Prevent Web Browser Open on Startup

As of the most recent update (4.26.2), every time I open Unreal it launches Google Chrome and goes to the Epic Games Store page. How do I prevent this? It’s just obnoxious, and we obviously already have the store app installed.

Happening on 4.25, too. It’s been like that for a week or so. It takes me to a blank broken marketplace page…

Up please !

This is getting infuriating. I’d really like an answer to this solution; I’m trying to make games, not buy them.

I thought I solved it by disconnecting my google account from Epic, and there was a blissful day and a half where it wouldn’t open the Epic store. Alas, it was but a fleeting moment, and I’m back in the hell of Epic forcibly opening my browser to tell me about the amazing mega-sales going on whenever I try to open the engine for work. Would like some sort of acknowledgment that this bug even exists at all!

Yeah this is super dumb. Especially when I already have the launcher open it should recognize that, and not open a whole new browser tab. Extreme negative reaction to them making this decision. Not a good sign.

For now I’m going to block the “epicgames” domain in my browser. Using “block site” extension

343594-2021-07-08-10-47-50-block-site-get-this-extension.png

not sure if there is an official fix but here is what i did. First to describe my issue, my epic game launcher would launch but everything i clicked on in the ue5 marketplace would open up a browser tab. To fix this i simply had to close the launcher through task manager and relaunch it. The problem seems to occur after i launch UE5.

You just start Task Manager by holding CTRL, SHIFT, and ESC. Then, find the Startup Tab, click on Chrome if it is on the list, and click Disable at the bottom-right corner of the window.