Download

How to prevent execution blueprint's construction script when I am opening it for edit

Hello, I am accidentally created infinity loop in my big blueprint. Now I can’t edit it at all, UE4 is going to die every time when I am trying to edit it :frowning: How can I solve this problem? Heeeeelp.

Uff, i don’t think you can stop it from executing. You could only do this if you put an EDITABLE bool and a branch in front of everything
and setting it to false, but since you can’t open if, you have a problem.

You should really look into “Source Control” to prevent this for the future. Then you could just go back to the BP version that worked.
Now you could have run into a problem where you need to remake the Blueprint.

But you can still wait. Maybe someone knows how to workaround this for now. But like i said. Get yourself SOURCE CONTROL and you
don’t need to fear things like this again.

Try setting your Maximum Loop Iteration Count in the Project Settings/General Settings/Blueprints area to 0, instead of the default 100000

If that works, fix your problem code and then return that setting back to the default.