How to Play Animation Blueprint From Pawn?

I have a pawn blueprint that is based off of a parent blueprint called BP_PawnTank. I’m using this blueprint as the player. The blueprint has a CapsuleComp, a BaseMesh (Skeletal Mesh), a TurretMesh(Skeletal Mesh), a ProjectileSpawnPoint, a SpringArm, a Camera, and a custom HealthComponent. I created all the models and animations, and have imported them into Unreal from Blender.


I also have a BlendSpace for my animations, and it is setup with a horizontal axis called Angle and a vertical axis called Speed. I also have an animation blueprint set as the blueprint. I have this set to play the blend space animation with the angle and speed as inputs. (AnimGraph Picture) In the BaseMesh, I have the correct animation blueprint selected. (AnimBlueprint Picture)


In the even graph for the BP_PawnTank, I get the angle and speed of the root bone of the pawn, cast to the animation blueprint, and set the Angle and Speed. This outputs an angle between 0 to 180 to -135, and a speed from 0 to 600 if going straight, and over 800 if going diagonally.

However, the animation blueprint does not run. There are no dots going from the blendspace to the output pose in the AnimGraph. Any help is appreciated. Thanks!

I put this into my ABP_BaseAnimation Event Graph and removed the stuff in the Pawn tick function…

When I play, spawn in the character, and start tracking that object for debugging, I get no animations and no numbers in the top left. All I get is two 0.0’s at the beginning.

hey there , first of all , you may prefer to update directly in the anim bp more than from the pawn (you are using the event tic, but you should use the anim bp :


then, to monitor while playing, be sure to select the correct instance here :
(use shift + F1 to get back the mouse in play mode)


1 Like

I’ve tried that. The problem is that it only calls once at begin play, and never again. I get a 0.0, 0.0, and then nothing. If I keep the Anim BP open, it keeps giving me 0’s

Get Physics Linear Velocity”? Are you using physics to move the character?

I am not using physics to move the player.

the event “update animation” should trigger every frame (almost) you may did something wrong referencing your pawn (maybe casting to the wrong class)

Ok, I’ll look at it again to make sure everything is how you guys’ve suggested.

I have updated my question with more information from what you guys suggested. Still not working.

Anything else I could try?