Download

How to pause anim montage for couple of seconds then continue playing

i want to pause anim montage mid playing then on another event unpause it. how do I do this?

Only way I can think of right now is to use an animation snapshot, save out the time the montage was playing at, and use that time to re-start.

There’s other ways to pause things depending on what you are doing. So if the montage isn’t the only thing to pause time dilation may be the simpler answer.

it’s an attacking animation but it’s not long enough for me so I want to pause it at a specific moment for couple of secs then continue playing. also I saw there’s a montage section, isn’t that useful?

Yes you can probably split up and adjust the animation like you want with a montage.

The better way is definitely to just add frames in a DCC app of your choice.

how can i export the animation? i dont have the original animation

From the animation, you can export it as FBX with a preview mesh and LOD settings.

When putting it back, you can export just the armature. The mesh is unimportant.

i did things that u said i animated i the way i wanted and exported it back to unreal but for whatever reason the mesh seems to be deformed or invisible, I can only see small part of the mesh, does anybody know why? the rotations and scale was applied and I only exported the armature. did i make a mistake in blender?

… I don’t think I could possibly have made a mistake on something you did… so let’s assume that’s a typo…
Still, I have no idea if you made a mistake or not in blender… how could I? Unfortunately I’m not clairvoyant, though sometimes I do wish I were.

Did you select the existing skeleton when importing the animation?
No?
Bad, delete the skeleton that was created and re-importing using the existing one - and making sure it isn’t modified in the process.

Yes?
Then the mesh won’t change at all unless the skeleton is somehow scaled, so:

Is your blender set to use the correct scale?
No?
Start over after setting the scale correctly.
Yes?
Then the animation would play with the preview mesh normally…

yeah i made a typo Lol.

the flow between unreal and blender is really terrible. it’s so easy to miss an step and screw the whole thing up, i think the problem is with scale being applied after animating. i will redo the animation and see if it get fixed.

guys i wan able to resolve the issue. i had to apply the scale first then animate.

thanks for the help btw

1 Like