Download

How to package APK file using UE 4.23

Hi,

I have version UE 4.23, but I cannot package. After tried to package APK redirect to: https://docs.unrealengine.com/en-US/Engine/Tutorial/Mobile/SettingUpAndroidTutorial.SettingUpAndroidTutorial/index.html

Is there any settings for this?

Still need your help thank you.

Hi. You need to provide more details, logs, etc.
We can’t help if we don’t know what are you doing.

From where I can get logs?

Complier process show log from

Hi,

I got only this:
LogWindows: LaunchURL http://docs.unrealengine.com/latest/INT/Engine/Tutorial/Mobile/SettingUpAndroidTutorial.SettingUpAndroidTutorial/index.html
LogSlate: FSceneViewport::OnFocusLost() reason 0
LogSlate: Took 0.004811 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Editor/Slate/Fonts/FontAwesome.ttf’ (139K)
LogSlate: Took 0.003987 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Slate/Fonts/DroidSansMono.ttf’ (77K)
LogUObjectHash: Compacting FUObjectHashTables data took 0.59ms
LogWindows: LaunchURL http://docs.unrealengine.com/latest/INT/Engine/Tutorial/Mobile/SettingUpAndroidTutorial.SettingUpAndroidTutorial/index.html

How to resolved?

You need to install codeworks. Check the documentation here:

and after that here:

to make sure you didn’t miss anything else

Thanks a lot. That works.

I have only new issue after want to package APK.

I tried a lot of different issues from this forums, but the issue is still not resolved.

UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): UnrealPak terminated with exit code 0
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Copying NonUFSFiles to staging directory: C:\Users\Ryzen\Documents\Unreal Projects\MyProject6\Saved\StagedBuilds\Android_Multi
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): ********** STAGE COMMAND COMPLETED **********
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): ********** PACKAGE COMMAND STARTED **********
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): ERROR: Android toolchain NDK r18c not supported; please use NDK r14b to NDK r18b (NDK r14b recommended)
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): (see C:\Users\Ryzen\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.23\Log.txt for full exception trace)
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): AutomationTool exiting with ExitCode=1 (Error_Unknown)
UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): BUILD FAILED
PackagingResults: Error: Unknown Error