How to not spawn enemies one above the other?

Hello everyone, i made an spawn of enemies using an collision box in an actor blueprint, it spawn an enemy for each 15 seconds in a random place around this box.
But if this spawner spawn an enemy in the same place where already is another enemy, this enemy stays above the other enemy
There is a way to check if there is an enemy on the exactly random place in the box, and if it is, don’t spawn?

Hello vitor080vitor. I believe you can achieve this by changing the collision handling in your SpawnActorFromClass node that you are using to spawn your enemies.

Theres a couple options you can use such as try to adjust location or maybe just don’t even spawn. I hope I understood your question correctly. Hope this helps.

but i am using “spawn IA from class”… there is no option about this in there, just an boolean option saying “no collision fail”

hhhhuuumm i think i get it, but i didn’t undestand this number “20” in float, what is this? (on branch == vector)

Just check if in your spawn location is another enemy, if so just get another location.

It’s tolerance. 20 means 19=25 for example

Cause your actors are bigger than just 1 cm, instead of 20 you should get about the size of your enemys

hhhuuummm i get it, thanks… and sorry for taking so long to see your answer