How to not generate Hit Event on specific Actor?

Hi everybody,

My question seems stupid but I can’t find a way to do that. I just want that my Projectile, when fired, doesn’t make a Hit Event on my Main Character. I saw several post on forums that there is a method “Ignore” in blueprint. However, I just found the “Ignore Actor when moving”, but it doesn’t made what I just described. Anyone got a solution?

Try using an if object!=object node.
Specifically if hit actor != main character then do whatever.
If it is false (the hit actor is the main character) then just leave that blank.

Alternatively you can use if class!=class
Like this:

(Ignore the other purple wires not going into the comparison node)

Maybe try using a custom collision for your character, and set the projectile to ignore that type of collision?

No, that won’t solve my problem because the “hit” will still have effect (so my character will be block)

I don’t think so. There should be a simple way ! What I ask is not that complicated !

Have you tried collision channels?

You can create a custom collision channel in project settings. Then you can set this new collision channel for the Character to use. Lets call this ‘MyCharacter’. Then goto the collision properties of your projectile’s collsion component. Within the collision channels settings, make sure it is set to either ‘Ignore’ or ‘Overlap’ (if you want it to generate overlap events) against ‘MyCharacter’ channel.

I think I will do that, it the simpliest way to make it efficient, thanks for your answer, now it works… thank you !!