Download

How to Manually Update Plugin? (Simplex Noise in Particular)

Hello All!

I’m trying to use the plugin Simplex Noise for voxel terrain generation (props to DevDad!), but when I enable it in the plugins tab and restart the engine, I get this error;

"The following modules are missing or built with a different engine version:

UE4Editor-SimplexNoise.dll

Would you like to rebuild them now?"
After I press yes, I get this on trying to open the project;

“Project could not be built, please compile from source”

What I have tried to fix this:

  1. right clicking .uproject and generating VS files.
  2. deleting Binaries and Intermediate folders
  3. checking the .uplugin file for errors
  4. rebuilding the source by clicking the .sln and pressing F7
  5. using an old version of UE4 (4.11.2)

None of these have worked so far, and I am stumped. I think this is because the project is made in 4.7 (I think?) but people have reported back fine using it even in 4.12. Is there a way to manually update plugins? What could I do to fix this :(?

                                                                       Thank in advance to the community!

You need to compile an up to date version from the source - should work just fine. I actually just ported the code into my blueprint function library for the project and removed the need for the plugin myself.

I’m glad you are able to get it working :)! But I don’t understand how to port it into a BP function library, or compile a new version… could you please explain? I’m using a BP project, if that matters.

You cannot do it without touching code.

I don’t mind using code. I’ve actually just swapped over from Unity, and the BPs look more efficient for me. I’ve already created an empty C++ actor, so I should be good to use any code in my project now. How could I update the plugin?

Edit: Ah, Ambershee! I see you’re a moderator, is the right place to have this thread or is AnswerHub a better place for this?

Could a moderator please move this thread to AnswerHub? Or if that isn’t possible, I can just make a new thread there.

Thank you!

You’d need to work in C++, since simplex noise requires bitwise operations that aren’t available in blueprint. The plugin does come with source code on github though, chances are all you need to do is just recompile it in the current engine version.

I can’t move threads to the answerhub (they are different pieces of software), so you can just create a new thread.

I’ve found the answer, quoted from Pauly1987!

"Hi guys after hours of troubleshooting I got it to work ! I made a project added a c++ file to the project, saved and quit then installed the plug in in the engine content plug in directory and tried rebuilding project manually and didn’t work so was about to give up again but I copied the simplex noise folder from the plug in source directory to source directory of the project itself and rebuilt and I have the nodes ������ hope I helped PS:This is my first post on the forums "

Hope it may help someone later!

any progress in this isuue