How to make Unreal use GPU instead of CPU on Daylight /Outside game levels ? #UE5

Hi, I’m new to all of this and have been learning and building a game for almost a year now. Started when Unreal Engine Early Access 5 came out. Now using 5.0.3. I’m a complete noob so please speak to me like you are speaking to a child with no experience.

My porblem is:
I have 2 version of the same level (same actors, same everything) only difference is 1 is a day scene has daylight and shadows, the other is a night scene (only light source is torches around with 90% darkness overall). Both in Editor and in Packaged game, Day level uses 100% of CPU and 10% GPU, causing an unplayable game with 1 or 2 FPS I think. But the Night level (which is basically the same level without sunlight) has no issues, fluent graphics, 40 to 60 FPS and using 75% GPU and 12% CPU. What can I do to get at least 30 FPS from that Day Level too? or How can I make Unreal to use GPU for that Day Level too? (Both for the Editor and the final Packaged game)

Info on level:
I have a small open world level that has almost 1200 actors, ocean (water body ocean/mesh actor that affects the landscape), volumetric clouds with skylight/atmosphere, exponential fog, 8 npcs, 7 buildings. Many actors are from marketplace, copy of each other, has medium details.

Gaming Laptop (good fans): RTX 2060, i-7 10750H 2.6ghz (works 4ghz on full) 16gb Ram, SSD with 50gb more free space.

What I already tried and did not work:
Setting Nvidia preffered graphic processor to “high performance processor”
activating GPU lightmass
setting Lightmass importance volume
Decreasing most detailed actors and cancelling some shadows
Removing volumetric clouds completely
Baking lights inbetween these things.

Maybe my CPU is bad for this type of work but then, not every player who wants to play this game has a power pc. I need a way to turn this project into “all GPU” or “90% GPU” if possible.
Thank you so much in advance.

Hey @cemsend1, thanks for posting, and welcome to the forum!

Without knowing how you’ve specifically set up your lighting, there are a few tips I can give you. If you go into your Project Settings, under General Settings->Framerate, there is an option to “Smooth Frame Rate” which allows you to set the min/max FPS for a scene.

Other than that, I suggest checking out: Performance Guidelines for Artists and Designers | Unreal Engine Documentation

I hope this can help, and I hope your project goes well!

Thank you so much Zen for the quick response.
I read the article and am being careful about all that as much as I can. Unfortunately none of those solves this problem. Same level without the daylight works perfectly fine using GPU. I need a sharp method to turn this type of levels use GPU instead of CPU.