How to make translucent lit?

All translucent materials are unlit and I have it all set up right. When I switch back to opaque everything is fine. Are lit translucent materials also not possible with the new rendering?

They also show up as black in the material editor.

Hello Davision,

Lit translucent materials are quite possible with the new forward rendering approach! It can be easy to over look some of the settings within your material in order to get them to function properly. Follow the steps I am about to provide to get your translucent materials to work.

Steps to follow:

  1. Within a new or existing project (with the starter content) right click on any diffuse texture and choose “Create Material.”
  2. In my case I used wood, even though Im pretty sure there is no such thing as a translucent piece of wood, but let us image it does exist. :slight_smile:
  3. Now within your “Material Details” change the “Blend Mode” to “Translucent.”
  4. Within the “Translucency” section change the “Tranlucency Lighting Mode” to “TLM Surface”
  5. Now create a “ConstantVector” by holding “1” and left clicking in a blank space.
  6. Set this value to around “0.25”
  7. Plug this constant into the “Opacity” of your material.
  8. Apply and Save.
  9. Place your translucent material on the desired mesh to see the effects.

Here is an image to help you as a reference:

Thank you and I hope this helps!

Andrew Hurley

That options is gone in 4.8. When turning metallic up to 1.0 it just gets black. Metallic, Specular and Roughness don’t show up in the render buffers.

I would also like to know this too. I am trying to place a decal material on a unique mesh using vertex alpha to control the opacity, why can’t the material be lit?

Did you read over the post I provided? You can definitely use a lit translucent material with an opacity mask on a decal.

Could you show me the material you have for your decal so I can see how you are attempting to set up your decal actor?

Thanks,

Andrew Hurley

Thanks for your help, so I’ve got a translucent surface, default lit, and it’s working ok. Though the “TLM Surface” option is not there now, it’s been replaced with other things, could you tell me which one I want, I am making a plaster/exposed brick decal. So I don’t want it lit like water or glass obviously.

Also the roughness is greyed out. I can achieve a similar look by using “Deffered Decal” as the surface type, what’s the benefit of doing it the way you’ve described? Cheers

Here is an example I have set up to use as a deferred decal that works with translucency, and acts as a masked/translucent decal actor like a rusty stain.

Deferred Decal - Material Set Up

Here you can see I have connected my texture samples alpha channel to the Opacity input and assigned a constant value for the Roughness.

Here is what the decal looks applied to a surface.

Let me know if you have further questions.

Cheers,

Andrew Hurley