How to make the world fully unlit?


I’m working on a Paper2D game and i’m wondering how can i make sure my sprites and textrendercomponents unlit?
Currently when i play the game my white background is grey-ish and white textrendercomponent show up black as if there is no light (which there isn’t, because there shouldn’t be, it should be fully lit without any lights).

I’ve looked at Tappy Chicken and the SideScroller2D sample but couldn’t find any setting that mattered.

Sprites automatically already use the MaskedUnlitSpriteMaterial from Epic, but it’s just not fully white.

Sprite settings:


Unlit vs Lit:

In the material, set your Shading Model to Unlit and use emiss

ive for passing in your sprite texture.
Here is Epic’s default sprite material:

You can use higher values than 1,1,1 for emissive color. If you put 1000,1000,1000 in emissive color on an unlit shader it is fully white.

Ok, from your images it seems the Unlit functionality is not unlitt for some reason. I will check up on this later. That would be an interesting bug.

BTW, could you try turning off all the lighting features and post processing?

Not sure how much there is to turn off. I got a PostProcessingVolume in which i disable bloom and AA. There are no lights in the map.

You may try two things:

a. Issue “viewmode” command directly in C++:

GetWorld()->GetGameViewport()->HandleViewModeCommand(is_lit ? TEXT("lit") : TEXT("unlit"), *GLog, GetWorld());

b. Manually change ViewMode:

    FEngineShowFlags *flags = GetWorld()->GetGameViewport()->GetEngineShowFlags();
    GetWorld()->GetGameViewport()->ViewModeIndex = (is_lit ? VMI_Lit : VMI_Unlit);
    ApplyViewMode((EViewModeIndex)(is_lit ? VMI_Lit : VMI_Unlit), true, *flags);

You should try deleting that Post Processing volume.
Auto Adjust might be to blame here.
Be sure to check your camera’s settings and disable auto adjust brightness there too.

First one works wonders. Thanks.