Download

How to Make Particles Not Move With Model in a Blueprint

Hello. Newbie here. This is my first UE4 project, so I’m pretty clueless.

I added a simple blueprint with a static model of a rocket ship to the blueprint FPS starter project. I added a smoke particle system to the rear of the model in the same blueprint. It looks great: smoke comes out of the back of the rocket. However, when I shoot the rocket with the gun and the rocket moves, the already-emitted particles move and rotate with the rocket. I’d like for existing particles to float without reacting to how the rocket model moves. How should I construct this?

Thanks in advance for all replies.

  • Kert

There is a tick box in Required section of the particle system named Use Local Space, make sure that’s disabled.

Thanks! This did the trick. It works fine now. I don’t know how I missed that checkbox.