How to make Invisible Mesh but Animations still run the Footsteps?

I use the animation blueprint for markers to play audio for the footsteps on my character. How do I make it so that I do not have to display the default white robot guy mesh but instead have nothing but still play the animation. Here’s a attached video of the problem:

nvm cant post it, lmk if u need it.

Also bonus if you can keep the mesh shadow in but not the actual mesh!

Under your Skeletal Mesh Component inside your blueprint

  1. go under Optimization
  2. Set Visibility based Amim Tick Option → Always Tick and refresh bones