How to make basic click / touch and drag-camera movement? // Issues with with reading input

I have a pawn blueprint with a camera attached, and I want to be able to move the pawn / camera by dragging on the screen. I tried lots of things but for some reason nothing seems to work, and I finally found out why.

For whatever reason, the input-boolean seems to be false at all times. What am I doing wrong? How would I do the basic movement?

I thought about that too, but removing the Touch 1 and it’s boolean setters completely changed nothing. I also tried adding an Enable Input-node to Event BeginPlay, still without results.

Could you try temporarily disconnecting the Touch 1 Pressed and Released execute pins? I’m wondering if those are somehow interfering. Make it so only the left mouse click changes your Input boolean values. Let’s see if that gives you different behavior (it might not — just narrowing things down).

Are the Left Mouse Button pressed/released events being executed at all? Have you tried hooking up some debug print messages to each of those to make sure they’re working?

I found the cause of them not being executed at all - for some reason my pawn blueprint class was set to not take input at all. If somebody reading this has the same problem, go to the blueprint’s defaults and uncheck Block Input. Everything is working as intended now :- )