Download

How to make an Actor surpassable by other objects

Hello guys.

I have some health pickup and when I shoot them, the projectile bounces away.
I just want the projectile to completely ignore the pickup and keep going on its way.

To solve the problem I went to Project Settings -> Collision and then I created a new Object Channel and a new Preset: http://prntscr.com/8u1vai

Then, I went to the Pickup Blueprint Class -> Selected the collider -> Collision (from the details tab) -> Collision Presets (custom) -> screen: http://prntscr.com/8u1w60

After all… nothing happens…
The projectile still bounces when it collides with the health items…

How to solve?
Thanks in advance!

Easiest way: find pickup mesh in content browser, double click it and set to no collision (remove collision).

Another way is what you did but turn all collision, leave only overlap for pawn and other things you need to interact it with.

Or disable collision for collide with dynamic.

First do you know what it’s bouncing off of in the actor, like is it hitting the mesh or maybe hitting something else ?

I set NO COLLISION both to the Collider and to the Mesh.
The problem is that now the pickup ignores everything, even the collider of the character (and in this way, I cannot pickup the health).

Screenshots:

  1. http://prntscr.com/8u3bdx
  2. http://prntscr.com/8u3bl5

UP, please!

“leave only overlap for pawn and other things you need to interact it with.”

Instead of setting your collision to no collision, set it to custom, and change all the check boxes to ignore, except for pawn (or whatever else you want to pick up health)…that you’ll set to ‘overlap’

Alright bro, thanks guys! It works!

Set to OVERLAP, and use ON Overlap event.

Also follow some tutorials about pickups.