Download

How to lower the amount of RAM the editor is using?

I notice as I add more to a level the amount of RAM drastically increases. Is there any way to lower this? Especially for things in the scene that are culled. 200-300 objects in an entire level using 10GB ram is not ideal… I also notice if I change levels it usually keeps using the same amount of RAM as the last level, even if the new level would otherwise use 2-4GB if you had opened it first. How do I “unload” the things that are far away/not on screen other than culling, since culling doesn’t seem to lower the amount of RAM used.

Culling only affects the GPU, not RAM.

AFAIK the engine will clean up the RAM when necessary, so as long as it doesn’t affect other programs, why bother?

I was not aware that it would do this, some reason I’m still skeptical though because I’ve seen the engine try to use more RAM than is available and crash… Which is why I’m curious on how to lower it.

I assume this is not intended behaviour. Though I personally never reached my RAM limit with the engine as I don’t work on massive levels.

I just tried testing it again and it used to much memory, crashed and froze the entire system. How is one supposed to make an open world game if you can only add in 200 or so objects in one level and then it uses over 16GB RAM? So is it a bug that needs to be fixed with the engine? Is it because of high res textures? I need a way to tone down the ram usage while being able to place things in the level…
The engine is using 2%CPU & 2.5GB RAM when opening the first person example map when first starting up the engine.
2-7%CPU & 4.8GB RAM on my main game level(before I try adding a few hundred more objects to the level)
I tried doing a search and wasn’t able to find enough information yet on this topic, so if anyone has any advice I’d love to hear it, thank you.

Without adding anything and it still staying at 4.8GB RAM, I noticed while turning the camera to look at an area with a lot going on it crashed and this was in the log “[779]LogRHI: Timed out while waiting for GPU to catch up on occlusion results. (0.5 s)
Assertion failed: bSuccess”

Update: I noticed right before it would often crash(may or may not be related to RAM usage) I’d see a bright flash of lens flare on the screen. I turned off lens flare, specularity & ambient occlusion & it still crashed, but this time it didn’t mention anything about it in the log.

This does sound like a bug.
Look at my RAM usage, its around 750mb right after creating and opening a new first person template project. Im using a freshly compiled 4.22.1 build:

Reconfirming after restarting engine again, first person template is using 2.5GB RAM & .6GB shared RAM. Wow I don’t think mine has ever used that low of an amount of RAM as yours TrinityGER. I’m using default C++ first person template with apex destruction & web browser plugins turned on(no other plugins are installed/turned on other than the default). I’d report it if its a bug as it seems to be but I don’t like having to fill out all these forms for bug reports, I’d rather just report it on the forums. I think there’s actually two bugs, one with some objects in the level causing the crash, and the other with RAM usage. Also note that my version of unreal is compiled from 4.22.1 source on Linux.

From 4.10-4.18, I’ve never seen the editor in-use when it hasn’t ‘maxed-out’ Ram
Just doing basic level design and testing in PIE without any actual code eats ram…
UE4 will often start at the ~2 GB level, but after 1-10 PIE runs, it starts maxing out.
Starting a second editor session can release some, but often it just swaps to disk…
I thought it was the Landscape editor but its not. The editor just soaks up all 12GB…