How to Load EXP, Level, and Map Data?

I have gotten to the EXP part of making an RPG game. It can save the data but doesn’t load it onto the UI.
Here are my blueprints for the save system for the EXP.

What I mean is that it doesn’t display the EXP or level how it was after I save. It puts the EXP and level back to it’s default value.

Not sure I understand that set-up at all. You have 3 different “slot” names…how are you planning to save and load data from slot if you keep changing the name? You check if a save game exists in the slot called “GameSave”, if there is data there, you then ask to load the data from a slot named “Progression”??? You also on the same sequence have a second load game node but this time asking to load a game from a slot named “CheckPointSave”? When you say “it can save the data” are you just saying you get a print string at the end? Because the way I see it, unless you somewhere else saved a game to slot “GameSave” that execution path should always fail. But maybe you did, then it succeeds and saves a game to “Progression” and prints a string but this is a weird saving mechanism. Not sure what you are going for here with all this. Some clarification might help.

You are setting your variables backwards! In your very first screenshot of this post you “load game from slot” then you “set” the save game variables to the player default values…not what you want at all. You want to set PLAYER variables TO save game values, so everything from the save game output should be a “get” node, never a “set” node. When you save the process is reversed…you then only use “set” nodes from the save game and “get” nodes from the player character or wherever your variables you want to save are stored. That is why you always have default values haha

I meant to type progression instead of GameSave. CheckpointSave is for the character location when they overlap a checkpoint I made. I changed game save to Progression. The only problem I have now is that I can’t load the EXP and Level variables onto the UI. It sets them to the default values and yet it still saves them.
Here is the EXP bar Blueprint

And here is the Level text blueprint

Sorry for the confusion. That’s my bad.

I thank you. It works now now. I followed a tutorial on Youtube by a guy named Virtus and all his other tutorials worked up til now so I’ve been going back and forth trying to find other methods. One of them worked so no I don’t need anymore help. Thank you very much for your input.

You are setting your variables to the defaults and saving them in the BeginPlay() of the ThirdPersonCharacter instead of loading them.

This is what setters look like so you are basically saying “If there is a save game take the character defaults and save them.”

Instead you should be getting them and saving them in the ThirdPersonCharacter. This is what a getter looks like:


EDIT: I don’t currently have EU4 installed on this machine so I cant show you the correct setup but I hope you understand tour mistake.

Happy coding :slight_smile:

I realized what I did wrong. I have now fixed what happened and can now make a shop functionality. Thank you for your help.

Glad to hear that :slight_smile:

You can mark the question as answered if you have indeed fixed it.