Download

How to link in windows .lib?

Hi All,

I want to link in WS2_32.Lib to do some UDP networking stuff.
Is there somewhere that explains how to do that?

I saw this wiki page but it seems more for those who are modding the engine code?

I added the winsock2.h and that compiles fine without any actual code added.
But I tried to add the lib and its x64/x86 paths to the VS config but it won’t build/compile as soon as I add any winsock code.

Is there a manual somewhere on this?

Cheers
Fred

Sorry to bump but would be very happy to hear how to do this?
I tried doing the stuff in my link and it runs through without complaint but the still wont let me program using winsock bits.

I started testing ue4 sockets but am a bit put off by reading in forum posts that it is not well documented. Is this still a good alternative for low latency udp stuff?

Cheers, F

Hello Fredrum,

I am also fighting with the same issue.

In my situation, all code compiles and run properly under simulation mode.

When I run under standalone ode, I get some “Accessed none” error messages on class which is using sockets.

Did you resolve your issue ?