How to launch Code Project to iOS on Windows? 4.13

So 4.13 just released and i read that you can NOW Launch code projects to iOS on windows. But you still need a mac. Can someone explain to me step by step on how i can launch code projects on windows? Cause i’m planning on getting a mac soon and i’d like to know the Step-by-Step process on Launching a code project to iOS WITH Windows and NOT on a mac, i heard that you only use mac as a remote build or something? idk, i’m new to the concept lol thanks!


If you go through this [information on the forums][1], it’ll teach you about Rsync. You’ll need to make sure that you have a Mac computer available for compiling the code in your project.

Please let us know if you have any further questions, thanks!

Windows -> iOS Rsync/Remote Build Guide (4.8) - Mobile - Epic Developer Community Forums

When i press “Generate SSH Key” i get this error C:\Delta Copy\ ================================================================================ Connecting to as nikoskipz to create an SSH Key. Please note the following: It may prompt you about “authenticity of host can’t be established.” You must enter yes It will then prompt your for your password on Finally it will ask your for a ‘passphrase’ for your new SSH key. Do NOT give it a passcode, just hit enter Hit enter again when prompted to confirm. ================================================================================ Press any key to continue . . . ssh: connect to host port 22: Connection timed out ================================================================================ Now we will connect again to to download the generated private key. You will have to enter your password again. The private key will be stored in: “C:\Users\nicho\AppData\Roaming”\Unreal Engine\UnrealBuildTool\SSHKeys\\nikoskipz\RemoteToolChainPrivate.key If you want to share this key with others on your team, copy the contents of SSHKeys directory to: …/…/…/Engine/\Build\SSHKeys and then put it into your source control. ================================================================================ Press any key to continue . . .

My mac Remote Login is setup like this

What did i do wrong? i followed all of the steps in the link, you gave me.

Hey gotgrassct,

  • What about selecting ‘Account access for: All Users’?
  • Make sure your certificates are always set to ‘Always Trust’

To do this, open Keychain Access

  • Select System from the left hand menu
  • Select Certificates from the left hand menu
  • Select one of the installed Epic Games Certificates
  • Right click on the certificate and select ‘Get Info’
  • Expand the ‘Trust’ options
  • Set ‘When using this certificate:’ to ‘Always Trust’

Let me know if that resolves the issue for you, thanks!

It didn’t work…

I’m going to post the instructions as detailed as possible and hopefully you’ll recognize a step that you’ve missed:

Set up remote hosting on Mac:

  • Open the System Preferences > Sharing on the Mac machine
  • Check the Remote Login checkbox
  • Open Systems Preferences > Networking
  • Note the computer IP address, you’ll need it later on
  • Open Keychain Access
  • Select System from the left hand menu
  • Select Certificates from the left hand menu
  • Right click on the certificate and select Get Info
  • Expand the Trust options
  • Set When using this certificate: to Always Trust


Since you’re in 4.13, please verify that Engine/Extras/ThirdPartyNotUE/DeltaCopy exists. That’ll contain the Binaries, Source, DeltaCopy.tps and DeltaCopy_License.txt.

Setup Editor for SSH:

  • In the Editor: select Edit > Project Settings > IOS > Build > Remote Build Options
  • Enter the Remote Server Name (Computer name or IP of the Mac)
  • Enter the RSync Name ( name of the Mac)
  • Link the Delta Copy install path
  • Press the Generate SSH Key button

SSH Key generation steps:

  • Press any key to continue…
  • Enter remote workstation’s password
  • Enter Passphrase (usually blank)
  • Enter Passphrase again
  • Press any key to continue…
  • Enter remote workstation’s password
  • Press any key to continue…
  • Close Console

Once you’ve went through all of these steps, you should not have any trouble setting up remote building on your Mac. Make sure that you’re getting the right IP address from your Mac.

Let me know if these detailed steps have helped you further, thanks!

I Keep getting some errors during the build… Here’s the log. [link text][1]

108031-buildlog.txt (12.3 KB)

I’m able to generate an SSH key just fine with no errors, but as soon as BUILD COMMAND starts, i keep getting those errors in the buildlog.txt i showed you.

Install cygwin ( - default install), open Cygwin64 Terminal and do:

chgrp.exe Users /cygdrive/C/Users/nicho/AppData/Roaming/Unreal Engine/UnrealBuildTool/SSHKeys/nicky/nick/RemoteToolChainPrivate.key

chmod.exe 600 /cygdrive/C/Users/nicho/AppData/Roaming/Unreal Engine/UnrealBuildTool/SSHKeys/nicky/nick/RemoteToolChainPrivate.key

The group “Users” can be different if your windows is not in English. (In my computer is “Usuários” because my windows is in Portuguese)

Source: TIV.NET: Cygwin: Permissions 0660 for '~/.ssh/id_rsa' are too open.

It’s saying “No such file or directory exists” or something like that.

Sorry i just copy and pasted your parh from buildlog.txt above and forgot about the space in “Unreal Engine” folder. Try with:

chgrp.exe Users /cygdrive/C/Users/nicho/AppData/Roaming/Unreal\ Engine/UnrealBuildTool/SSHKeys/nicky/nick/RemoteToolChainPrivate.key

chmod.exe 600 /cygdrive/C/Users/nicho/AppData/Roaming/Unreal\ Engine/UnrealBuildTool/SSHKeys/nicky/nick/RemoteToolChainPrivate.key

Or just cd to folder /cygdrive/C/Users/nicho/AppData/Roaming/Unreal\ Engine/UnrealBuildTool/SSHKeys/nicky/nick/ and run the commands without the path

Just got it to work! THANK YOU! The problem is that cygwin doesn’t accept spaces. To make it work, every directory that has a space in it’s name i had to put a “****” for example : “C:/UE4/My Documents/Folder” Would be like this instead “C:/UE4/My\ Documents/Folder” So just add in that Backslash for every directory and file name that has Spaces and you’re good to go! And that’s what got it building for me! Thank you!

I’m having some new errors: PackagingResults:Error: Error Deployment failed! Failed to sign executable. Make sure your developer certificates have been installed in the System Keychain on the remote Mac.

BUUUT I Already have my certificate installed in the System Keychain…

Check if your private key is accessible for any program in the System Keychain (double click the private key then click Access Control).

Building for iOS on Windows | Unreal Engine Documentation - see Mac Setup step 3 see also

It’s set to Allow All applications to access this item. I went on my Apple developer account, downloaded the certificate from there (Because the “Export…” button is greyed out in Xcode when i try to export my development signing identity from there) And placed it into my Login Keychain and System Keychain and set them both to “Always Trust”. I Download the same certificate for my PC and import it to my project. Everything shows up valid. But when i build, it tells me to check my System Keychain for a certificate. What the heck?

Sorry to bump up this question but just to clarify: from 4.13 do we absolutely need a Mac to package our projects from Windows? I mean projects thought for mobile IOS (and I made some trial with the 4.10 with no problems even today with just my PC)

If you are getting the permission 0660 errors, the solution to my problem along with 7ortis7’s answer was something else. I’ve already posted an answer in another post, I hope it helps you if you are having the same issues: