Download

How to Improve Frame Rate Through Video Settings

Hey guys!

We’re about to publish a new blog post by senior graphics architect Martin Mittring about improving performance in the editor and thought it would be helpful if we also copied it here for everyone on the forums to see. Check it out below. Please let us know your feedback and ask any questions you might have. We’re happy to help!

How to Improve Frame Rate Through Video Settings
by Martin Mittring

I’d like to share a few tips that will help you improve performance when playing with the editor.

Many UE4 developers are content creators who are building assets and games using fairly powerful machines with multicore CPUs, fast graphics cards and high-spec memory configurations but if you’re using a slightly lower spec machine, or if you want to make the editor even more responsive, you can scale down a few video settings to reach the desired result. Keep in mind that the more you scale your settings, the more it will change the look of your work, and some rendering features may even be disabled in lower spec settings.

You can find the scalability settings in the quick settings menu:

These settings are saved each time you exit the editor, so you may try restoring the settings to see the final look on a high-spec machine. Over time we will continue to refine the system (for details see BaseScalability.ini) – and we also expect games to customize this further.

We have many features that we can adjust for performance or quality. Most of them are only visual because this is where most performance is required, and those settings usually don’t have a strong gameplay impact.

All of those settings are grouped (e.g., Texture Quality or Shadow Quality) so the player has to manually adjust fewer settings. Each group can be in one of four states, usually low/med/high/epic.

Which settings are the best for you depends on your configuration (CPU performance and memory, GPU performance and memory), your personal preference (pretty or fast) and the content (many objects or complex materials). The auto button gives you good settings for starters.

Note that lower settings do not always result in faster rendering. This can happen because many specialized hardware units run in parallel. Scaling down a specific rendering feature might not affect the critical path and in that case it would have not resulted in better performance. The engine is optimized for a typical game workload (realistic materials, many lights, partly dynamic, many objects, and many effects) and a wide range of target platforms. That means we’d rather have a lower base fps but have less impact when we add more details.

Some hardware might just be too slow to run the editor but a modern desktop (not laptop) multicore CPU with a decent DirectX11 graphics card should give you a very good experience.

The game settings are stored separate from the editor settings. Changing the game settings is a bit more involved but I can cover that in a separate post if you’re interested.

Thanks for this. I was able to increase my fps a bit through this method while I wait for my new card. I for one would definitely be interested in a guide on adjusting the game settings. =)

+1 for “game settings” topic.

Buy better hardware .-. haha
Funny thing is after 30fps on Mac I can’t really see if it is faster or just the same. On Windows I notice bigger framerate differences though.

the launcher updating stoping always by “81% 0b/s 71 Mb remaining ]”

:open_mouth: Is that fortnite?

Try again. If no success, reinitialize the engine and give another chance. Still getting problem? Or is an issue of your PC or you can try to reinstall the Engine.

PS: I had a similar problem as yours, but a reinitialization was enough.

Please show how to change game settings, I am trying to optimise the engine for oculus rift development and I am currently failing.

Yes please sir!

Same for me.

Cheers,
SRombauts

So, for future reference, the documentation on “Scalability” settings (for Editor and Game) is https://docs.unrealengine.com/latest/INT/Engine/Rendering/Scalability/index.html

But on how to use those commands… AnswerHub and the forums are full of questions about “scalability”, “graphic settings” or “performance settings” (dozens!)

So here is a short selection;
https://answers.unrealengine.com/questions/23023/trouble-configuring-game-settings.html: call the console commands of the documentation using blueprints to change Game settings at runtime

Menu Tutorial and Menu with Graphics Settings Change Tutorial would be nice - Feedback for Unreal Engine team - Unreal Engine Forums amiserablerobot shares video tutorials on how to integrate this on a “settings” menu
=> See the full Youtube playlist here, or start bellow with the first video:
https://youtube.com/watch?v=HDyE40mrXZM

Cheers,
SRombauts

EDIT: better links for future references

Hi all!

I came back to this issue, re-check AnswerHub and the Forums, but I am still struggling to get something fully working :frowning:

I spend some time experimenting with blueprints:
I am currently using a “Level Blueprint” where I map various keyboards keys to “Execute Console Command” and “Print string”, so I can check easily what is working and what is not.

=> For me, r.ScreenPercentage and r.PostProcessAAQuality are working fine, but other commands does nothing (while corresponding options in the Quick Settings menu does act inside the editor)
So I tried replacing “r.” with “sg.” but it does not work.

Any idea?

Finally, I got the solution of @amiserablerobot working, I posted an explanation here, an I will do a small tutorial in those forums;
https://answers.unrealengine.com/questions/31421/scalability-reference-does-not-apply-to-standalone.html

Cheers!
SRombauts

Thanks Jeff, I also found that setting the viewport to “unlit” improved frame rate on my laptop when working in the editor.

Excellent summary SRombauts.
Thanks.

I am so frustrated because I am experiencing just around 10 frames per second. I have tried tweaking the settings and it hasn’t helped at all. I am so incredibly disappointed because of the fact that I have a top of the line computer. I have an Alienware 17 with an i7-4710MQ @ 2.5 GHz AND 16GB of ram. I also have a AMD Radeon M9 M290X graphics with 4GB of GDDR5 running at 64bit. I really want to utilize Unreal Engine 4 now because it has just recently become free, but I simply can’t because the frame rate is so poor. I have checked my computer settings and I am running on High Performance mode, not power-saving, I continually scan my computer for viruses/malware, optimize my operating system and disk drive, keep my registry clean and defragged, scan for any vulnerabilities, and ultimately try to keep my pc in tiptop shape. I am so frustrated because I have spent so much money on this computer and it has been great so far besides trying to load up Unreal Engine 4. Is there some way I can allocate more memory to Unreal Engine 4 which could possibly be the problem? I would like to get this problem solved because I firmly believe that my computer should be able to run Epic settings at optimal performance, yet it is running 10fps at the lowest settings. Thanks.

Just off the top of my head could you try to get a picture or video with stat unit

Also what kind of scene are you running? Is it full or geometry and shaders with hundreds to thousands of instructions? Are you using a lot of post-processing?

My 3-year-old laptop with integrated intel hd 4000 can run landscape demo around 30 fps with settings turned all the way down and third-person template at 55fps with settings all the way up.

Hi,

Thank you

Maybe **Build > Lighting Quality ** & Material Quality will Improve Frame Rate ?

Resolution is a big problem. Trying to render at full screen resolution will make almost any hardware suffer. I saw a legendary GTX 690/i7 Extreme Core build struggle to run the third person shooter demo at 30 FPS, 1440x2560. If you’re running a high resolution desktop, you CANNOT run the viewport at a large size in full detail. My current PC is an i7 4770k (really good), NVIDIA GT 640 (average-low), 1080p monitor (very good), and I can get a 30+ FPS experience for the most part if I make the viewport a little smaller. If I upgrade to a GTX 970, I’m sure most of the issues with framerate will fall to the wayside. This engine is not getting any more difficult to render*, but luckily computers are becoming more and more capable of running it.

*If you want to run dynamic GI, that will be another story. But out of the box, performance is actually a lot better.

I’m only running a GTX 660 and get 60fps in the TPS demo, and upwards of 40 in most things - Elemental, etc - at 1080. I think there was somethin’ amiss with the machine you saw that on