How to import PBR materials from C4D properly.

Hi! I’ve just started exploring the world of Unreal Engine and I don’t know yet whether I’m doing something wrong or it is a Datasmith’s plugin imperfection…
I’m using PBR materials in Cinema 4D and cannot achieve the same look in UE.
Please, note that when I’m saying that I’m using PBR materials I mean the PBR approach when you use such channels as:

  • color
  • reflection
  • roughness/glossiness
  • normal

But the material in Cinema 4D is standard which is supposed to be supported by Datasmith.

Below are some examples of my textures in C4D and in UE. And here is the same material in Sketcfab live demo:…c8005d9825d8bb
Please, help to solve the problem.



Could you upload that test model (c4d file + texture) somewhere, so that others can test the import too? Cannot download the sketchfab file ^.^ For my imports i modified the master material a little bit, but i also use an ancient C4D R15, which is the last version without PBR, so i would not want is that as a reference. But since your model does, a comparsion would be possible, to see, if it gets imported the same way as my files from the older versions.

One thing i see, your sketchfab file says for PBR, that it uses specular workflow, as far as i know, UE uses metallic workflow.

Thank you for the reply, Suthriel!

Maybe this causes the problem indeed. I didn’t know about that…

Here is the test C4D file with textures:
Unfortunately, I cannot attach it to the forum post because it exceeds the allowed file size.
And yes, it is done with a specular workflow.

Thank you in advance!

I tried the metallic workflow and no result. The imported material looks different, but also incorrectly.
For me, it looks like UE expects C4D’s material to have a specific set of textures set in specific order and hierarchy. But I cannot guess that “magic recipe”. I tried different workflows with different combination of reflection channels just randomly changing them, but couldn’t get the proper material look. And in Datasmith documentation they don’t describe the requirements for the material settings.
Here is one of the examples of how I do that:

Ok, have tested your scene, and unfortunately, here come several problems together:

A. The material, which UE/Datasmith creates for the C4D models is still funky, and needs to be changed, some checkmarks unchecked, others activated (and for convinience, maybe some nodes added to the master material ^.^ )
B. Yeah, you will need to convert your textures to metallic workflow, which… isn´t the easiest way, unless your C4D contains a button, or node or baking function, which let´s you bake out all those textures for metallic workflow. Or… since you already got a texture set, where did you made them? If whatever program you used to create those textures, have the ability to give you the metallic textures, then grab them. I know, that f.e. substance painter can create both specular and metallic workflow sets (Quixel cannot, they use metallic only, maybe switch to them for texture creation;) ).

If neither C4D nor your texture program comes with the luxury of easy conversion, i found an older kind of tutorial, that shows you a more or less accurate way of converting it manually.

For A:

Go into the during import created material and

  • deactivate “Use_ReflectionColor”, dunno who thought, that this is somehow accurate, but this causes the biggest problems, since until now, the Datasmith plugin cannot recreate any of C4Ds shaders or functions. Maybe it would work, if those shaders etc. could be recreated, but until that happens, turn it off.
  • deactivate “Use_Specular”, because C4Ds Specular node has absolutely nothing to do with the specular workflow or specularity, it´s an ancient relic from the Pre-PBR-era to fake specular lights.
  • activate “Use_Metallic”, this will give you access to those nodes, where your metal-texture needs to go, or where you define, if your whole material is metal or non-metal, like leather or plastic
  • rest of the nodes would be self explanatory, like normal map or ambient occlusion.

Little explanation, what would go where:

  • your Albedo/Color/Diffuse texture would go into the Color segment. If you cannot see a texture slot, then activate the “use ColorMap” first, and set mixmode to normal (multiply would mix the chosen color with your texture to give it a different tint). In metallic workflow, the texture would look like a combination of your engine_COL and engine_REFL textures from your model. Any missing texture slot will pop up, if you check “Use xxxMap”
  • Reflectance is the segment, thats responsible for the roughness stuff (inverted glossiness), so your roughness texture goes there
  • Metallic is the segment, that gets your metal texture (will be a black and white texture, marking segments as either metal or non-metal, usually nothing in between), for this you first have to activate “Use_MetalicMap” (that typo is real :slight_smile: ). Or if you don´t have one, use the slider to define, wheter your whole material should be metal or a non-metal.

Thank you very much for the detailed answer! I’ll work on that. A lot of things became clearer now.